Thread Rating:
  • 4 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Engine cutting out, oil in inlet and on cam cover (pictures)
Hi folks,

My 2003 1.9 diesel Berlingo (non turbo) now struggles to cut out while driving a few times, and got progressively worse - now it won't stay running for more than a few seconds.

There's either oil or diesel on the top of the engine under the inlet, looks like it could be leaking from injector 1?

There's also a lot of oil in the inlet from the airflow meter through the butterfly/EGR assembly and all up the inlet manifold, but particularly on the runner closest to the oil/diesel on top of the engine (see pictures attached)

I was thinking it's a leaking injector, but the oil level in the sump seems fine. I haven't compression tested it but it wasn't smoking at all. Is it worth me cleaning it all out and seeing if it runs or is it something more serious?
Any ideas guys?
The oil/crud in the inlet could be from the EGR. Block it off. Is your cat blocked/collapsed. We had this happen in a Renault and it gave similar symptoms i.e. not running for very long.

Your pictures seem to have vanished. I'm sure I saw them there a few days ago.

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
Thanks Malc, I'll check the cat at the weekend. Yeah no idea where the pictures went!

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 39
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 50
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 21
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 103
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 243
Bump and Run - Am I right...
Last Post:Jed Clampit
Yesterday 10:13 PM
» Replies: 11
» Views: 161
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 135
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 82
Dead BSI unit?
Last Post:Kez
Yesterday 07:22 PM
» Replies: 4
» Views: 117
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 204

Locations of visitors to this page