Thread Rating:
  • 7 Vote(s) - 2.57 Average
  • 1
  • 2
  • 3
  • 4
  • 5
stopped for 5 min. temp gauge in red..................
and a red STOP on the clocks, along with a bleeping

this if the best pic i can get, it flashes off and on

[Image: IMAG0208.jpg]

ive checked the coolant, its between the min-max but brown as hell

[Image: IMAG0213.jpg]

also checked the oil, again its between the min-max but removing the cap it looks a tad dry

[Image: IMAG0209.jpg]

[Image: IMAG0210.jpg]

so what is that all about? i only bought the car today (cheap enough) and did 100+ miles no problem, this all started when i stopped when i got home.
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
You really should have looked at the oil and coolant before you bought it...

First off, check the quality of the oil.
If it's discoloured, (brownish), you have a major problem(cracked block, kaput head gasket or something)

Does your fan operate?
(I'm guessing that it doesn't)
As long as you drive, the additional air coming through the radiator probably manages to cool it off, then you stop and the wind disappears...

Drain the sludge and flush the system.

Is this a car with or without AC?
If it's without AC, there's a temp sensor mounted on the radiator. Test it if it works by connecting a multimeter to the connectors, lower it into boiling water, and read the resistance before and after.

With AC?
(Does the AC work?)
The temp sensor sits on the thermostat housing.
(The AC controller controls the fan)
Temp doesn't look in the red to me, are you sure you're not looking at the fuel guage? .............
Somedays you're the pigeon, Somedays you're the statue.
(29-06-2013, 07:34 PM)steve valentine Wrote:  Temp doesn't look in the red to me, are you sure you're not looking at the fuel guage? .............

it not in the red as i took the pic an hour after turning the engine off.
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
Similar thing happened to me a couple of weeks after buying mine...stuck in traffic for 10 mins and up went the temp and on went the stop light. Pulled over, squeezed the hoses to get the coolant around and hopefully ease any possible airlocks and away again with no problems. Then a few days later the temp went up in traffic, fans came on, the temp went right down below normal before rising again and on came the stop light.

Turned out to be a sticking thermostat....bled the system properly when fitting new one and she's as good as gold now.

Hope that might be of some help.
i bought a new thermostat but it still happened, i dont think i bled the system properly though Sad
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
Bleed screws are at top of radiator, top of thermostat housing, and heater at the back wall(unless you have AC. Then I have no clue)
If there's air in the system, it should get trapped in those areas as soon as the coolant starts circulating.

Was the old thermostat failed?
(Closed when cold, opens when dropped in boiling water if it's OK)

Did you flush the coolant while you were at it?
(No reason to keep the old sludge... It will eventually pack up the radiator)

And most importantly, does the fan work?
The Citroën engines are very compact, so they don't have a lot of 'extra' metal to distribute heat across, so a problem with the radiator or fan will very quickly bring it to a boil. The fact that the lamp comes on when the car isn't moving tell me that it's the fan.
(The front of the Berlingo is open enough to let in a decent amount of air while it moves, so a fan failure won't strand you in the middle of a highway/autobahn/motorway/whatever. It is killer in slow traffic, though)
[+] 2 users say Thank You to Gadgetman for this post
had an airlock, took me about 3 days to get it all out Sad
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
If it took 3 days to get rid of the air,I would suspect the water pump impeller.If made of metal they can erode due to cavitation,causing bad circulation making it more prone to overheating in traffic.
That's my story & I'm sticking to it.
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Oh, he's talking about the car? :whistle: I've spent days purging excessive hot air.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Today 10:16 PM
» Replies: 8
» Views: 238
Bump and Run - Am I right...
Last Post:Jed Clampit
Today 10:13 PM
» Replies: 11
» Views: 141
splayed rear wheels
Last Post:david.mckay.3760
Today 10:01 PM
» Replies: 5
» Views: 78
Still on the elusive 4x10...
Last Post:doofer
Today 08:47 PM
» Replies: 3
» Views: 129
Car smell...
Last Post:doofer
Today 08:03 PM
» Replies: 1
» Views: 67
Dead BSI unit?
Last Post:Kez
Today 07:22 PM
» Replies: 4
» Views: 104
srceen wash pump.
Last Post:landcrab
Today 07:18 PM
» Replies: 7
» Views: 196
replacing diesel fuel pip...
Last Post:geoff
Today 05:13 PM
» Replies: 35
» Views: 2008
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 04:57 PM
» Replies: 0
» Views: 27
M49 1.9 diesel misfire a...
Last Post:jj9
Today 12:29 PM
» Replies: 3
» Views: 111

Locations of visitors to this page