Thread Rating:
  • 7 Vote(s) - 3.43 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] Overheating problem
#1
Help please
Hi I have a Citroen Berlingo multispace forte 1.9 diesel (51 plate) on a trip yesterday 16 miles (motorway) half way there and the stop sign came on, checked the water before I left and it was full. Stopped and had to put 2 litres of water in it?, the fan was racing for 10 mins after stopping, carried on the rest of the 8 miles and the temp gage went up and down , about an inch of water less when I got there. Got more water for the journey back and it was ok except for the radiator light flashing on and off . Checked all the usual signs for cylinder head problems no steam from exhaust , oil level ok and water still ok. The only noticeable thing is the fan is loud when I stop and takes a while to go off. Any help appreciated
Reply
#2
Is there water in the footwells? Just thinking of a leaking heater matrix if there are no other visible leaks.
Griff
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
(15-07-2013, 11:17 AM)Landmark Wrote:  Is there water in the footwells? Just thinking of a leaking heater matrix if there are no other visible leaks.
Griff

Thanks for answering , no nothing in the footwells.
Reply
#4
Try flushing the cooling system & changing the thermostat.
:thumbsup:
Strawberry flavoured windows  Dodgy
Reply
#5
It's normal that the fan runs after the engine is switched off, if the engine got very hot. And yeah, it's noisy.
Does your car have an AC?
If not, there's probably a thermoswitch on the radiator itself, which controls the fan directly. (The fact that the fan is running would then definitely mean that the thermostat works. There's no way for that area of the radiator to get that hot without liquid circulating)

The big problem is 'where did the 2 liters go?'
(I assume that it didn't boil when you stopped to add water?)

Are there no wet spots under the car?

The fact that the temperature 'jumped up and down' on the return an be because of air trapped in the system. (There's a few bleed screws for that)

There's two hoses going between the radiator and engine. The top hose leads water from the engine, and is connected to the thermostat housing. If this hose is very hot, it's an even bet that the Thermostat is working as expected.

You will have to replace some of the water with proper anti-freeze(Glycol) soon, as the mix you're running now is mostly water and will cause lots of damage to the system in the long run.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 98
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 38
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 64
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 42
Berlingo Parts
Last Post:Sb12
Yesterday 07:56 PM
» Replies: 0
» Views: 42
Rear hub nut torque setti...
Last Post:jj9
Yesterday 07:55 PM
» Replies: 15
» Views: 280
temperatue dial
Last Post:Kokain
Yesterday 05:28 PM
» Replies: 3
» Views: 93
Trip Computer on Type A M...
Last Post:cancunia
Yesterday 03:50 PM
» Replies: 0
» Views: 36
Loud beeping from radio u...
Last Post:nicko
Yesterday 03:49 PM
» Replies: 3
» Views: 126
Ligts won't go off!
Last Post:Berlingos12
Yesterday 02:50 PM
» Replies: 10
» Views: 475

Locations of visitors to this page