Thread Rating:
  • 6 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2.0 HDi Revving uncontrollably
#1
I'd be really grateful for some advice here.

A few days ago the OH took our 2004 2.0 HDi out for a drive, and on the way back the engine suddenly began to rev without her putting her foot on the accelerator - masses of black smoke from the exhaust too. She was able to pull over and turn the engine off, but was very scared by it. She called me. Luckily it was a small and straight road with very little traffic.

When I arrived 25 minutes later I started the car - perfectly normally - and drove it home. Nothing like that happened again.

A day or two later on a long downhill drive - about 3 miles with the engine on overrun in third gear all the way, just using the brakes at corners - the engine management light lit up on the dash. There were no other symptoms - the car seemed to drive perfectly well.

When the car cooled down and restarted the light stayed off (and it still is).

Should I be biting my nails and expecting something really awful to happen soon? I wouldn't fancy the first fault if it happened on a motorway, for example! Could this be something to do with the EGR? Any suggestions at all about what might be wrong?
Reply
#2
It sounds as though your engine is feeding on its own oil. You'd need to investigate whether its coming through failed seals in the turbo, or the crankcase breather system.
Reply
#3
(16-07-2013, 11:09 AM)addo Wrote:  It sounds as though your engine is feeding on its own oil. You'd need to investigate whether its coming through failed seals in the turbo, or the crankcase breather system.

Thanks Addo. It has only happened once. If it were failed seals in the turbo, wouldn't I expect it to happen (for example) whenever I accelerate hard? And would I expect it to be using oil? (as it doesn't seem to be). Not water either.

That said, the exhaust does always seem a bit smelly - not smoky, just a smell. But I rather thought that was just normal for a diesel.
Reply
#4
Just a short update. I never did find out what had caused this, not for certain, but I think - with hindsight - the engine oil level was probably excessive and it was a hot day: I'm guessing oil was pulled into the engine via the sump breather (if that is possible?). In any event, I had the oil changed and refilled to the correct level, and, several thousand miles later, nothing similar has recurred.

The engine is still a bit smelly (not smoky) at times and I'd guess that IS the EGR. But I'm told blanking it off is difficult with the 2.0 HDi.
[+] 1 user says Thank You to Araucaria for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Heated wing mirrors
Last Post:Bricky Ken
Yesterday 11:57 PM
» Replies: 0
» Views: 15
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Yesterday 11:07 PM
» Replies: 1
» Views: 81
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 765
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 114
Door locking but unlocked
Last Post:DanielEZY0252
Yesterday 09:45 PM
» Replies: 0
» Views: 11
12v for lighter front
Last Post:Jed Clampit
Yesterday 09:07 PM
» Replies: 8
» Views: 183
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 69
zx1 extralube
Last Post:sks01773
Yesterday 06:07 PM
» Replies: 0
» Views: 42
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 05:57 PM
» Replies: 5
» Views: 133
2012 enterprise berlingo ...
Last Post:Johny555
Yesterday 05:37 PM
» Replies: 9
» Views: 211

Locations of visitors to this page