Thread Rating:
  • 2 Vote(s) - 3.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hello and can someone help please?
#1
Hi folks.

I bought a new shape 2009 Citroen Berlingo van three months ago. Fairly high mileage 130k but its got lots of bells and whistles and came in at the right price.

My question is this;

Heater/blower fan stopped working completely last night and I don't know why. Air Con light still comes on when pressed and I think I can hear the valve/solenoid click in the engine compartment, but nothing from the fan in any switch position 1-4.

I've got the owners handbook but it doesn't specify which fuse is for the fan. I checked them all anyway, both in the passenger's foot well and under the bonnet. All fuses seem ok.

I am a domestic electrician by trade, so I do know a bit about what I'm trying to fix.

Is there someone out there who will say "ah yes, the old blower fan not working fault" and point me in the right direction?

I have heard all kinds of scare stories about fan motor resistor packs failing, rotary switches costing £125, even a dodgy ignition switch, but my 27yrs of fault finding experience tells me to check the basics first.

Thanks

TJ
[+] 1 user says Thank You to welshwizard for this post
Reply
#2
Hi there and welcome to the forum have a search on the site there are quite a few threads on this subject and its usually the fan resister pack that has failed. Lighty has posted on this topic you could search out his posts.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#3
Yes, loads of stuff on here about this issue. This is a mark two thread but a starting point:

http://www.berlingoforum.co.uk/showthrea...ght=heater
Reply
#4
Hello again folks.
Got it sorted.
Burned out relay next to fuse panel. Cost £2.74 to fix.

Happy bunny Big Grin
[+] 2 users say Thank You to welshwizard for this post
Reply
#5
Why isn't life always that simple?Confusedcratch:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:willpisme
Today 07:48 PM
» Replies: 2
» Views: 23
Poor cold startup 1.9
Last Post:jj9
Today 06:57 PM
» Replies: 23
» Views: 600
Fuel consumption
Last Post:ron
Today 06:28 PM
» Replies: 9
» Views: 196
peugeot charger
Last Post:Johny555
Today 06:06 PM
» Replies: 2
» Views: 53
Washers not working
Last Post:CourierJim
Today 05:38 PM
» Replies: 3
» Views: 48
Anti pollution
Last Post:Caylin46
Today 05:04 PM
» Replies: 5
» Views: 602
Heyup
Last Post:polar
Today 05:03 PM
» Replies: 7
» Views: 301
Amateur radio
Last Post:nicko
Today 04:06 PM
» Replies: 25
» Views: 8256
Apple Carplay
Last Post:Solent
Today 03:58 PM
» Replies: 0
» Views: 18
Haynes manuals - which on...
Last Post:Trevor
Today 03:53 PM
» Replies: 6
» Views: 73

Locations of visitors to this page