Thread Rating:
  • 3 Vote(s) - 3.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Central locking query
#1
Hi guys, my van (2005 1.9d) has remote central locking, it locks fine with the remote (ie locks the van, flashes indicators) but will not unlock it. It flashes the indicators etc but does not actually physically unlock the doors, I have to do that manually with key.
I've had a read on here & come across the bsi reset thing which I have tried but made no difference Angry
It's not a major problem at all infact I'm used to it now however if there is an easy fix/solution you guys know of I'd be very pleased to hear it :thumbsup:
Thanks in advance chaps Confusedalut:
Reply
#2
Anybody? Sad
Reply
#3
Just a thought when you try and open the doors with the remote can you hear the central locks trying to work. Could it be that the drivers door master has seized up or getting stuck some how and hasnt got the force in the motor to unlock. May be worth taking the drivers door panel and having a look. You could isolate each door lock to see if it is one of them causing the problem.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#4
(25-08-2013, 07:53 PM)Tomcat3 Wrote:  Just a thought when you try and open the doors with the remote can you hear the central locks trying to work. Could it be that the drivers door master has seized up or getting stuck some how and hasnt got the force in the motor to unlock. May be worth taking the drivers door panel and having a look. You could isolate each door lock to see if it is one of them causing the problem.
No clicking or noise whatsoever, also forgot to mention that the central locking wont unlock the car at all even using the key instead of remote. You have to 'pull the pin up' retro style lol. All doors lock fine with the remote or key.
Reply
#5
Have you had a read of this thread it may be of use http://www.berlingoforum.co.uk/showthrea...al+locking
Have you had a look at the wiring that passes from the door pillar to the door, sometimes they break and let water in go corroded and play up.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#6
(26-08-2013, 06:45 PM)Tomcat3 Wrote:  Have you had a read of this thread it may be of use http://www.berlingoforum.co.uk/showthrea...al+locking
Have you had a look at the wiring that passes from the door pillar to the door, sometimes they break and let water in go corroded and play up.
Thanks for that will have a play Confusedalut:
Reply
#7
I had exactly this problem with my 2005 2.0 HDi Multispace (saloon). I could lock the doors with the remote but had to put the key in the drivers door to unlock, then use the levers on the other doors.

I tried everything, including BSI reset. I checked the door solenoids by applying 12 volts to the door contacts. They worked fine so it had to be a control problem.

I think you may well find that the problem lies in a poor contact in the BSI. But it is easy to fix. You need to remove the BSI first. This is the hardest job as there a a number of plugs and access is poor. But with patience it can be done. When you get the BSI out (after having shut it down in the recommended way) you will see it is enclose by 2 halves of a case. The case needs to be removed to reveal 2 printed circuit boards attached to each other by two blocks of pins. These are quite delicate but the boards need to be separated by levering the pins apart. You need to take care as it would be easy to damage the boards and/or pins.

Once you have the boards separated you will see that one contains the control section, with on board chips etc, and the other is a servo section containg relays. 2 of these relays control the central locking. It's possible one of the relays is at fault but more likely that the connecting pins are not connecting. Examine the pins and the sockets on the boards with a strong magnifying glass, looking for signs of corrosion, dirt etc. Remove any you find with a small stiff brush. Reassemble the boards using a switch lubricant. You can get this from Maplins or CPC in Preston, mail order. I used Briggs SKL as an aerosol, but there are others. Squeeze the boards back together very gently, reasemble the case and install the BSI. Observe the correct restart procedure (see elsewhere on this forum)

If this doesn't work the cost will have been minimal, and a bit of fiddly work has been wasted]. But I bet this is the answer to your problem.

Afterthought - My tailgate didn't lock before I fixed the BSI, although the 4 doors did. After the fix they all locked and unlocked reliably and they still do, a full year later. Let us know how you get on.
[+] 1 user says Thank You to mikeB for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
2025 Diesel Ban
Last Post:doofer
Today 10:48 AM
» Replies: 12
» Views: 245
12v for lighter front
Last Post:cancunia
Today 10:42 AM
» Replies: 11
» Views: 236
Door locking but unlocked
Last Post:ffrenchie
Today 10:17 AM
» Replies: 3
» Views: 56
Rear seats
Last Post:doofer
Today 09:55 AM
» Replies: 1
» Views: 73
1.6 hdi 90bhp Turbo and i...
Last Post:Trevor
Today 09:46 AM
» Replies: 2
» Views: 101
lubricating door
Last Post:sks01773
Today 08:57 AM
» Replies: 0
» Views: 31
Heated wing mirrors
Last Post:3rensho
Today 06:00 AM
» Replies: 1
» Views: 47
how many miles on yours ?
Last Post:Silverberlingo
Yesterday 10:59 PM
» Replies: 17
» Views: 785
1.6 16v petrol cambelt
Last Post:geoff
Yesterday 10:24 PM
» Replies: 5
» Views: 142
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Yesterday 07:17 PM
» Replies: 5
» Views: 81

Locations of visitors to this page