Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hello! - Let me start by apologising
#1
Hello all
First off, sorry, I do not have a Berlingo
Hope thats OK
I have its country cousin, a 2001 Citroen C15 with DW8 engine and thats why I joined.
Hyenas manuals for this year of van are useless, they stop at 98-99 so I hoped learning a bit
about the Mk1 Berlingo with DW8 may reveal enough similarities to help me keep the shabby wee thing running.

I serviced it when I got it 3 years ago and fitted new glow plugs, cam belt kit, fluids, filters etc
and touch wood, its running fine so far
I've also removed all that EGR valve malarkey and cut out the CAT from the exhaust pipe.
the heater brushes went so I stripped it down and used brushes from a Bosch power drill to repair it and its worked fine since.

Hope no one minds me mooching about the place picking up bits of info

Reg
C15 interloper (I just snuck in one day)
[+] 2 users say Thank You to RegW for this post
Reply
#2
Welcome!
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#3
Hello Reg your welcome to the berlingo forum
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply
#4
Hi & welcome.I had a C15 before my Berlingo,it's a brilliant van.
Any help you need,just ask.:thumbsup:
Strawberry flavoured windows  Dodgy
Reply
#5
Lighty has a C15 as his shop van.
Reply
#6
Hi from another newbie.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 219
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 27
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1094
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 43
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 312
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 272
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 40
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 419
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 82
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 623

Locations of visitors to this page