Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
speedo 8mph high
#1
anyone know why my speedo always reads 8mph high at all speeds? i know the clocks have been changed but could this be the cause?
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
Reply
#2
Not sure about the UK but many countries require the manufacturer's to set them too high. Mine reads around 10% too fast compared to my GPS navi. Supposed to keep you from speeding apparently. Big brother looking out for your well being Cool
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
wouldn't be fussed if it was 2-3mph but 8 seems a tad much.
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
Reply
#4
What are you comparing your speed to?? GPS? The speedo may well be nonlinear and the gradations are in all probability not precise. I wouldn't lose any sleep over it.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#5
3 gps and those signs that tell u ur speed.
MK1 Berlingo, Y-Reg 1.4 Petrol Now LPG Converted.
Reply
#6
I would live with it as it is, at least you aren't likely to be speeding.
2010 (B9) Berlingo Multispace XTR HDi 112 - Kyanos Blue
Previously - 2002 (M49) Berlingo Multispace 2.0 HDi Diesel - Arctic Steel
Reply
#7
Standard size wheels/tyres? I know having a different rolling radius can affect the speedo reading but 8 mph seems allot.
'04 Peugeot Partner HDi LX. Lows, Leaks and Wellers. Now matt grey and dent free Smile

Reply
#8
same downunder, speedo reds around 5-10kph more than actual., if your bothered by it get your speed sensor checked.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page