Thread Rating:
  • 3 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MOT query
#1
So, the MOT is due on my mk1 Berlingo 2.0hdi next week, but, I have a bit of a problem. And by 'bit' I mean pretty massive possibly.

I have the non-functiong dashboard problem that seems to affect a good few people, so was wondering what the legality is with regards the dashboard/speedo. I have a fix in place, it is a device connected to my obd port that shows my speed/rpm/engine load/intake temp/coolant temp all at once, and as this would be more accurate than a needle on an analogue instrument I was wondering if this will pass an MOT?

I have seen that as long as the dashboard isn't clearly broken or that the speedo is slow to react to speed changes then it is a fail. But hoping someone else with a bit more knowledge can advise me, as frankly, I can't afford to put the van in for the MOT if it will fail badly, as there a few little other niggles too (slight knock on right rear, dipped left light pointing downwards etc etc).

Cheers for any help.
Reply
#2
Mine has gone through the last three mot's with a non functioning speedometer.
Somedays you're the pigeon, Somedays you're the statue.
Reply
#3
(07-10-2013, 08:33 PM)steve valentine Wrote:  Mine has gone through the last three mot's with a non functioning speedometer.

Ah, well that's encouraging at least then. Maybe just the rest of the niggles to worry about.
Reply
#4
How can they test a speedo? Is a road test or a rolling road part of the test now?

Our old Berlingo passed its test for 5 years with the mileometer reading 600000 miles and no one every queried it. The tester just asked if I had any idea what the true mileage was.

Peter
Reply
#5
(08-10-2013, 06:54 AM)Romahomepete Wrote:  How can they test a speedo? Is a road test or a rolling road part of the test now?

Our old Berlingo passed its test for 5 years with the mileometer reading 600000 miles and no one every queried it. The tester just asked if I had any idea what the true mileage was.

Peter

Well this makes me less anxious thats for sure. The only things that work on the dash are dipped/main/full beam symbols. Oil and air bag lights. So hopefully I can't be tripped up on anything else.
Reply
#6
Depending on how knowledgeable the tester is.....he may switch on the ignition
to look for the presence of all warning lights. If, for instance, your brake warning
light doesn't work then you may get an advisory.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#7
(09-10-2013, 11:38 AM)OlJeffers Wrote:  Depending on how knowledgeable the tester is.....he may switch on the ignition
to look for the presence of all warning lights. If, for instance, your brake warning
light doesn't work then you may get an advisory.

Well an advisory or 'more' I can live with, as really I plan to sell the van once it has it's MOT as I can't afford to run a vehicle at the minute. It's just whether the cost of fixing things is going to outweigh what I'd make back in selling it, as it can surely only be worth a few hundred quid.
Reply
#8
You can fail on an airbag warning light which doesn't come on with the ignition then go off again but the speedo isn't tested. He might notice it on the brake rollers though.
So where does this bit go then ?
Reply
#9
(09-10-2013, 06:13 PM)ffrenchie Wrote:  You can fail on an airbag warning light which doesn't come on with the ignition then go off again but the speedo isn't tested. He might notice it on the brake rollers though.

Airbag light comes on and goes off as normal, same with oil light. Just none of the gauges work, and indicators don't show inside the van, but they do work. The device I have attached to the obd port is perfectly accurate and shows more info than the dash does anyway, it even has the mileage stored on it in the settings.

I'll prepare my 'for sale' advert for it in advance though on other niggles ha ha.
Reply
#10
Can you please give more details of the device that you plug into your OBD connector

Peter
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 24
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1087
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 40
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 310
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 272
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 40
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 419
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 82
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 621
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 93

Locations of visitors to this page