Thread Rating:
  • 6 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oil Leak
#1
Hello
Everyone one i am new to this forum.
Have a citroen berlingo III changed oil filter the weekend
now i have oil leaking looks like between bell housing and gearbox any ideas?
Regards
Brendan.
[+] 1 user says Thank You to Brendan44 for this post
Reply
#2
Are you sure it's not some you've spilled during the oil change? Is the filter housing leaking?
Somedays you're the pigeon, Somedays you're the statue.
Reply
#3
When you changed the filter did you change the O-ring on the plastic cap as well??
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#4
Thanks for you help checked all them things the only thing is the filter i got looked a bit different the small tit that sticks out of the filter had a hole in it and there was a wing on the filter to locate it in the housing?
Regards
Reply
#5
The new filters do have the wing fitted, but it is a direct replacement.
As long as you got the pip located in the hole, all should be fine.
Best guess is that you didn't get the filter seal on correctly, and it has been bunched up on installation as you tightened it. It is imperative that you get the square section seal on straight all the way round, and not twisted. Then it must be lubed so it doesn't gather up. They are a messy job, we have had lots of practice, probably done 2or 3 a day for the last 5 or 6 years, that makes quite a lot Smile
[+] 2 users say Thank You to Lighty for this post
Reply
#6
Think i got the problem when i changed the oil filter the oil run down the gearbox and in around the clutch lever to the inside of the bell housing and run out the bottom thanks to all the replys.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Roof noise
Last Post:Opensauce
Today 06:39 PM
» Replies: 5
» Views: 101
12v for lighter front
Last Post:Matija Danko
Today 05:15 PM
» Replies: 19
» Views: 378
Poor cold starting. Whats...
Last Post:ron
Today 04:34 PM
» Replies: 4
» Views: 49
Fuel consumption
Last Post:ron
Today 04:30 PM
» Replies: 7
» Views: 124
Lexia clone that works wi...
Last Post:kennard
Today 04:22 PM
» Replies: 60
» Views: 1898
Repair a manual winder wi...
Last Post:cancunia
Today 03:31 PM
» Replies: 1
» Views: 31
lubricating door
Last Post:cancunia
Today 03:25 PM
» Replies: 4
» Views: 113
1.6 16v petrol cambelt
Last Post:cancunia
Today 03:19 PM
» Replies: 15
» Views: 341
Rear light Cluster
Last Post:Peter Guy
Today 03:13 PM
» Replies: 4
» Views: 102
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 87

Locations of visitors to this page