Thread Rating:
  • 2 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
various problems
#1
has anybody got any pics of what the driver side engine mount should look like mine got a big bolt sticking up through middle not sure if it right also there oil about injector 4 carbonised on top of engine anybody no how to fix this
Reply
#2
Google?? Smile
https://www.google.co.uk/search?q=citroe...40&bih=781

Leaking injector? (tighten it).....

Cheers Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#3
ive nipped them up a bit tonight surely if the seals were gone then it would be pissing out oil could this be the smell that in cabin when just about idling ?
Reply
#4
Drivers side mount should have bolt (as you put it) coming up through it with cap on top
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 17
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 88
2012 enterprise berlingo ...
Last Post:Col
Today 05:01 PM
» Replies: 4
» Views: 82
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1774
Water Heater - Glow Plug ...
Last Post:jj9
Today 04:30 PM
» Replies: 19
» Views: 518
Head gasket failure.
Last Post:david.mckay.3760
Today 04:28 PM
» Replies: 12
» Views: 312
Eco mode
Last Post:ghost123uk
Today 04:28 PM
» Replies: 21
» Views: 13756
2025 Diesel Ban
Last Post:dumdum
Today 02:46 PM
» Replies: 1
» Views: 44
Berlingo won't start 2009...
Last Post:Col
Today 01:49 PM
» Replies: 6
» Views: 142
Facial light replacement
Last Post:peteh80
Today 12:35 PM
» Replies: 5
» Views: 171

Locations of visitors to this page