Thread Rating:
  • 3 Vote(s) - 4.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Warning Light] engine management light
#1
Hello everyone need some help here, ive got a 2004 berlingo 2.0hdi, the problem is my glow plug light is intermittent when it comes on its very brief and after a few seconds the eml (engine management light) comes on but after about a mile or so of driving the eml goes out and its fine, but on the other hand when the glow plug light doesn't come on the eml comes on and stays on and only goes out when the engine is up to temp and I turn van off and on again? Any ideas as I find this very strange and don't know where to start first.

Many Thanks

Warren
Reply
#2
The glowplug light on the hdi only works at zero degrees and below. At zero it comes on for only one second -5 is about 5 seconds and -10 about ten seconds. It's probably not related to EML.
Somedays you're the pigeon, Somedays you're the statue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Fuel consumption
Last Post:ron
Today 09:41 PM
» Replies: 12
» Views: 260
Rear Wiper Motor
Last Post:minisandfords
Today 08:48 PM
» Replies: 2
» Views: 76
Lower Ball Joint
Last Post:brodfather11
Today 08:38 PM
» Replies: 2
» Views: 62
Bottom Ball joint
Last Post:Andyy
Today 08:26 PM
» Replies: 6
» Views: 73
peugeot charger
Last Post:geoff
Today 06:35 PM
» Replies: 4
» Views: 118
cutting out HDi 1.6 diese...
Last Post:Col
Today 06:15 PM
» Replies: 18
» Views: 1429
Poor cold startup 1.9
Last Post:Top drive
Today 06:10 PM
» Replies: 34
» Views: 793
hello
Last Post:ron
Today 05:22 PM
» Replies: 1
» Views: 33
starting problem
Last Post:brodfather11
Today 03:32 PM
» Replies: 1
» Views: 39
Washers not working
Last Post:Redjoe100
Today 03:25 PM
» Replies: 6
» Views: 144

Locations of visitors to this page