Thread Rating:
  • 4 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bad A/C wiring/electrical fault?
#1
Hi bros,

Have a small question to ask regarding berlingo mk1 A/C compressor. By default/based on experience, how long does it take for the A/C compressor (and radiator fan) to start after turning the A/C on?

Experiencing late kick in every now and then. A/C took more than 10 min to start after pushing the A/C button on. However once kicked in it works fine blows cold air. On normal days it turns on almost immediately (3-5 seconds, 30 secs top)

Suspect is bad relay in the fuse box or fan switch? Seeking advice from the gurus and bros here. Thanks
Reply
#2
Update from mechanic: Seems like wiring/electrical issue. One of the pressure switch pin has no power. Big problem is he can't remember which wire it leads to. Any experts' advice? Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 05:31 PM
» Replies: 3
» Views: 50
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 558
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 76
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 83
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 354
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 872
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 67
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 177
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 59
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 43

Locations of visitors to this page