Thread Rating:
  • 15 Vote(s) - 2.47 Average
  • 1
  • 2
  • 3
  • 4
  • 5
berlingo fault code P1336
#1
Hi I am trying to fix my sons 2004 berlingo 1.6 16v M-space petrol engine van...went into limp mode yesterday checked for fault codes and found
P1336 has been running fine for last year or so...citroen code shows this as Crank/Cam sensor range/performance...ME7.4.5. Combustion misfiring on unspecified cylinders...replaced Camshaft sensor cleared fault code running exactly the same limp mode...checked plugs cleaned them as they were dirty looks like excessive fuel...cannot find a Camshaft sensor and enquiry at motor factors show no availability of camshaft sensor...now at a loose end...appreciate any help
Reply
#2
Is it the Crank position sensor as opposed to the cam position sensor ? I've not seen it on Citroen but we had a faulty one on my daughter's Corsa and it made it run rough and start badly. It was a pretty easy fix just held in with an Allen bolt and a plug to connect. Here's one.
So where does this bit go then ?
Reply
#3
(22-11-2013, 06:09 PM)kneadman Wrote:  Hi I am trying to fix my sons 2004 berlingo 1.6 16v M-space petrol engine van...went into limp mode yesterday checked for fault codes and found
P1336 has been running fine for last year or so...citroen code shows this as Crank/Cam sensor range/performance...ME7.4.5. Combustion misfiring on unspecified cylinders...replaced Camshaft sensor cleared fault code running exactly the same limp mode...checked plugs cleaned them as they were dirty looks like excessive fuel...cannot find a Camshaft sensor and enquiry at motor factors show no availability of camshaft sensor...now at a loose end...appreciate any help

The later Berlingos have the camshaft sensor as part of the coil-pack .
Reply
#4
(26-11-2013, 04:10 PM)ffrenchie Wrote:  Is it the Crank position sensor as opposed to the cam position sensor ? I've not seen it on Citroen but we had a faulty one on my daughter's Corsa and it made it run rough and start badly. It was a pretty easy fix just held in with an Allen bolt and a plug to connect. Here's one.

Thanks for the input just to bring it up to date..changed crankshaft sensor...no change...stripped n checked timing belt in case it jumped, was replaced last year still ok...have replaced plugs and was left with possible coil pack faulty...whilst doing this I always rechecked fault codes which changed from 1336 to 1338 and then 1339...(which is misfire in cylinder 2 and 3)..took it to an indy who also checked fault codes with snap on equipment saw all 3 previous codes so his thought was... has to be the coil..so ordered one which came n when fitted... no change so says got to be injectors when checking shows up as No 3 cylinder appears faulty...going to change that injector..good news is new coil pack going back so am not £70 down for coil pack..cannot do job till Thurs so will take it from there...definitely prob No3 cylinder but with new crankshaft sensor new plugs new coil pack tried only leave injector or valve problem ? fingers crossed !
Reply
#5
Did you not do a compression check?
Strawberry flavoured windows  Dodgy
Reply
#6
sorry forgot to update did the compression check slight drop between no 2 n no3 cylinder...no other obvious signs of cylinder head gasket fault like oil in water ect...so bit the bullet head off sure enough head gasket slight line between cylinders new gasket rebuilt and all fine...indy didn;t charge labour for injectors ect very fair so all happy in the end...sometimes better to forget the fancy codes n go back to basics fuel spark compression ect..
Reply
#7
I hope you gave the valves a quick lap & changed the stem seals whilst the head was off.Confusedcratch:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Conversion from manual to...
Last Post:Civvic
Today 07:58 PM
» Replies: 1
» Views: 70
Rear seats
Last Post:Kevin Crisp
Today 05:17 PM
» Replies: 0
» Views: 34
12v for lighter front
Last Post:Matija Danko
Today 05:03 PM
» Replies: 3
» Views: 94
2012 enterprise berlingo ...
Last Post:Col
Today 05:01 PM
» Replies: 4
» Views: 89
Lexia clone that works wi...
Last Post:kennard
Today 04:42 PM
» Replies: 57
» Views: 1777
Water Heater - Glow Plug ...
Last Post:jj9
Today 04:30 PM
» Replies: 19
» Views: 527
Head gasket failure.
Last Post:david.mckay.3760
Today 04:28 PM
» Replies: 12
» Views: 324
Eco mode
Last Post:ghost123uk
Today 04:28 PM
» Replies: 21
» Views: 13768
2025 Diesel Ban
Last Post:dumdum
Today 02:46 PM
» Replies: 1
» Views: 48
Berlingo won't start 2009...
Last Post:Col
Today 01:49 PM
» Replies: 6
» Views: 149

Locations of visitors to this page