Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HORN WON'T WORK - MOT DUE
#1
Sad 
Hi Everyone, I have a 2005 Berlingo with the old non HDI engine. It's MOT is on Tuesday and the horn wont work. Dangling underneath the dashboard unattached is a small blue multi plug with around eight wires in it that appears to come from the back of the steering wheel, the multi plug has a black clip that you move through 90 degrees to lock into place there are also two larger brown plugs each with two male spade connectors in which are also unattached. All other electrical items appear to work and there are no warning lights still on. Could any of these wires be connected to the no horn issue?


Attached Files Thumbnail(s)
   
Reply
#2
Hi garry have a search on the forum for horn problems there is plenty on here about it. They can suffer from poor earth mounting and various people have done it by earthing out the column or the best way is to remove the airbag and underneath you will see the horn earth that needs mounting properly. I think there is a thread with that tells you how to complete with pictures. Perhaps others can remember the thread.
Have a read of this http://www.berlingoforum.co.uk/showthrea...ot+working
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 1 user says Thank You to Tomcat3 for this post
Reply
#3
Tried the suggestion of earthing the steering column and it works a treat!
Thanks everyone.Big Grin
[+] 1 user says Thank You to Garry for this post
Reply
#4
The only issue with earthing through the stearing column is that you may trigger a fault code or throw-up an engine diagnostics warning light.

The reason why earthing as you have works is that it earths via a path other than the designed one, so may cause issues elsewhere on the electrical system.

Took my Berlingo in for a fuel filter change and, as I have the problem with my horn, spoke to the mechanic. He told me that he has so far had 100% success by removing the earth lead from the back of the horn and replacing it with another one that goes directly to earth (rather than via a return loop back up through the stearing wheel).

This does require removing the front bumper, but will solve the issue permanently.

Incidentaly, he had done one just a month back, so was quite familiar with the issue.

The workshop I used was the Essex Fire service Workshop, so they are extremely knowledgable about vehicles and common faults.
Reply
#5
I fixed this on my MK2 MultiSpace by removing the air bag and wrapping a length of wire around the earth clip affair that goes in to the air bag mounting plate, I then slackened the steering wheel center nut and wrapped the wire around this a few times before torquing it back up. this worked fine - No fault code.
Reply
#6
Have the same problem, have just Had it 3 days so finding things out as i go along,the horn works fine with key out but not when running.
Also high beem n/s out and no book as to how to remove light,have sent for the Hains so hopefully will learn more then.
It's educational. John
Reply
#7
(07-12-2014, 02:22 PM)Patman99 Wrote:  The only issue with earthing through the stearing column is that you may trigger a fault code or throw-up an engine diagnostics warning light.

The reason why earthing as you have works is that it earths via a path other than the designed one, so may cause issues elsewhere on the electrical system.

Do you have any more info on this? I ask as my Berlingo has had an indicated over-heating problem for a while, yet it's had all new everything (Rad, upper/lower hoses, water pump, thermostat, and coolant) except for oil cooler and various minor pipes.

Maybe clutching at straws as the fuel gauge works fine, but I wondered if the separate earth lead I ran from the chassis to the steering column could cause erroneous readings.

The weird thing is, it easily drops to 80C now the weather is colder, but still rises to over 90C if under any hard acceleration or going over about 70 on the motorway or up a hill.


anyway, to the OP: I had the problem with the horn, but it seemed to resolve itself just by taking the airbag off, giving everything a spray of contact cleaner, and re-assembling.  I installed the seperate earth first, it didn't work.  The horn was fine with the key in accessory position, but did not work with the engine running. 
2004 1.9D Multispace/Budget crew cab work van!
Reply
#8
Have just been and done the jump lead from steering column to a good earth and its working as it should, so first opportunity it's air bag of,it looks like the previous owner as had a go as there is a torch screw missing?

On the high beam problem, the fuse is fine and I can get the bulb to work by running a wire from the fuse to the bulb so there's a break in the main power line from fuse to head light I think?

Learning all the time as Benny Hill  used to say.
Reply
#9
Just fixed the horn problem as per other postings, removed airbag and cut off black cable from original earth point( really useless Citroen obviously can make some money from peoples problems!!) Crimped ring connector drilled small hole alongside and fixed with self tapping screw, very simple thanks for the previous postings for info, onto the airbag switch now!!!! Longest part of job waiting 30 minutes after disconnecting battery
Reply
#10
Good to see you have it sorted
                                     Smile  It's too orangey for crow's It's just for me and my dog  Smile

                                                        Heart Heart Love a lot trust a few  Dodgy
 
                                                        

                                        
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Berlingo won't start 2009...
Last Post:Chri5
Today 12:22 AM
» Replies: 7
» Views: 167
Insurance!
Last Post:fcamp
Yesterday 10:52 PM
» Replies: 6
» Views: 822
citroen berlingo desire 1...
Last Post:sks01773
Yesterday 10:47 PM
» Replies: 2
» Views: 34
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 10:40 PM
» Replies: 0
» Views: 14
B9 DPF Tank Top-Up
Last Post:Lighty
Yesterday 10:06 PM
» Replies: 5
» Views: 112
Rear light Cluster
Last Post:Peter Guy
Yesterday 09:57 PM
» Replies: 2
» Views: 25
2012 enterprise berlingo ...
Last Post:CourierJim
Yesterday 09:03 PM
» Replies: 6
» Views: 118
Head gasket failure.
Last Post:Civvic
Yesterday 08:08 PM
» Replies: 13
» Views: 360
At last
Last Post:Gerald Bostock
Yesterday 08:06 PM
» Replies: 9
» Views: 327
Conversion from manual to...
Last Post:Civvic
Yesterday 07:58 PM
» Replies: 1
» Views: 88

Locations of visitors to this page