Thread Rating:
  • 9 Vote(s) - 3.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Starting problem
Hi All.. Any advice on this would be greatly appreciated..I have a 06’ model HDI 2.0 Litre. I am having problems with starting first thing in the morning for ages, even when the weather is not freezing.. When it eventually starts (around 7-8 seconds) there is a lot of smoke. I’ve changed the glow plugs twice, changed the relay, and I got my mechanic to run a cable direct from the battery to the plugs with a switch so I can heat them directly. None of this has helped . He tested the fuel pressure and its normal. Battery is also showing a full charge. Van runs very well apart from that...I’m running out of ideas!! Any help is greatly appreciated as I said...Thanks :brickwall:
I think the first thing I'd is to put a double dose of Millers EcoMax through the system.
Keep it simple! Get the fuel system clean before you look any further.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Ok, ill try that..thanks very much
Coolant temp sensor. ? . tells the ECU if the injection timing is to be advanced/retarded for easier starting ?
I was thinking it might be temp sensor but i put a new one on a few months back as it was faulty..There's no fault codes showing either
How old is the fuel filter?
Strawberry flavoured windows  Dodgy
Brand new fuel filter today..Van is always serviced religiously
Might be worth mentioning that when the van warms up, it will start all day again no problem each time, its only first time in the morning
My 1.9D had a similar fault which turned out to be valve clearances.

Stupid computer!
Security system should not fail safe!
Security system should fail dangerous!
[+] 1 user says Thank You to crickleymal for this post
Are the 2,0 HDi's hydraulic like the 1.6 HDi?
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
Just had a look and Ron's correct, they are hydraulic Big Grin
You learn summut new every day!
Cheers Ron. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
P1351 fault code.
Last Post:Boxer
Today 07:27 AM
» Replies: 16
» Views: 842
Lexia Scanner?
Last Post:brajomobil
Today 06:44 AM
» Replies: 1
» Views: 76
Dead BSI unit?
Last Post:brajomobil
Today 06:26 AM
» Replies: 3
» Views: 44
2012 berlingo radio setti...
Last Post:NANO_Vigo
Today 02:19 AM
» Replies: 10
» Views: 215
Black Smoke
Last Post:Jed Clampit
Yesterday 10:07 PM
» Replies: 3
» Views: 96
Strange exhaust blowing n...
Last Post:dieselj
Yesterday 10:00 PM
» Replies: 1
» Views: 49
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 365
DPF Regeneration
Last Post:Jed Clampit
Yesterday 09:46 PM
» Replies: 4
» Views: 79
New Battery
Last Post:Jed Clampit
Yesterday 09:35 PM
» Replies: 3
» Views: 71
Window mechanism replacem...
Last Post:Kez
Yesterday 09:01 PM
» Replies: 2
» Views: 70

Locations of visitors to this page