Thread Rating:
  • 26 Vote(s) - 3.15 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Leaking windscreen or aerial mount????
#1
Hi all, had a bit of heavy rain yesterday and today and have got some water ingress into the vehicle via the top windscreen rubber, or maybe the base of the aerial mount???

Has anyone had this problem before...... seems to be dripping in and pooling above the courtesy light fascia!!! Then dripping on my head when going around roundabouts etc Sad

Is this another lovely berlingo fault..... thought I had cured them all!!!

Yours hopefullyIdea
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#2
Have you tried a hat, Adam?:thumbsup:
Reply
#3
Can't find one big enough to fit the Berlingo's roof......???
would this affect the mpg do you think......Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#4
The leak?
Depends how much water gets in.
Anyway, it's not raining.:thumbsup:
Reply
#5
On mine it was the aerial base leaking. Picked up a new one and replaced it. Before seating it onto the roof i used a small amunt of clear silicon and has been fine ever since
[+] 1 user says Thank You to 800HDI for this post
Reply
#6
cheers,

have siliconed the outside of the mount where it joins the roof for the mo....
will do for a couple of months!!! Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#7
"Is this another lovely berlingo fault..... thought I had cured them all!!!"

and you haven't even started on the electrics yet !
Reply
#8
(06-06-2011, 07:39 PM)Coco Wrote:  "Is this another lovely berlingo fault..... thought I had cured them all!!!"

and you haven't even started on the electrics yet !

hmmmmmmmmmmmmmm.... lets not tempt fateSmile Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#9
This has been mentioned before so I don't think that you're the first with this problem unfortunately
2005 Berlingo Multispace 1.6i Desire (Iron Grey)

If everything seems to be going well, you have obviously overlooked something.


Reply
#10
I had the same problem and traced it to the aerial. When I took the aerial off there was two holes where the aerila fitted into the roof, rather than get the silicone gun out I fitted two different sized O-rings onto the aerial, nice tidy job and has not leaked since.
Roly

2004 Berlingo 600 Enterprise
Confusedafesex: If in doubt flat out!!Confusedafesex:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:cancunia
Today 09:51 AM
» Replies: 4
» Views: 57
2004 Berlino Aerial
Last Post:malgpz900
Today 09:37 AM
» Replies: 3
» Views: 55
2005 2.0 HDI Siemens pump...
Last Post:cancunia
Today 09:05 AM
» Replies: 1
» Views: 53
1.6 hdi 90bhp Turbo and i...
Last Post:peteh80
Today 06:58 AM
» Replies: 4
» Views: 229
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1106
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 320
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 284
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 423
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 89
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 631

Locations of visitors to this page