Thread Rating:
  • 2 Vote(s) - 1.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temperature problem
#1
Hi I have BERLINGO (M59) ESTATE VAN 1.4i 75 (TU3JP), I have changed thermostat fitting, and the water temperature sensor, but I still have problem with engine temperature. I need to drive at list 30 min to reach the temp of 85 C. Before that, engine temp is 60C but that is not accure. Water pump is ok, and everything else look good. Where can be the problem? Thanks!
Reply
#2
maybe a faulty guage? although the weather has been very cold so may just take a while to warm up?
Reply
#3
Yes, when the weather is too cold I have this problem. When the weather temp. is bellow the 0. What do you think, where it can be the problem?
Thanks!
Reply
#4
What temperature is it in Macedonia ??

Edit ..... I've just looked at a map to see where you are and it should be about 3 Centigrade.

If the gauge will read 85 when fully warmed up then it cannot be reading incorrectly as this will be the correct temperature, try placing something over the grill / radiator to stop cold air entering and see if it warms up any quicker, plastic sheet or cardboard will do the trick.
Watch out for overheating of course.

My 1.9D takes about 5Km to reach 85*C when 3*C
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Facial light replacement
Last Post:Mike
Today 09:23 PM
» Replies: 11
» Views: 278
Reverse light switch prob...
Last Post:willpisme
Today 08:09 PM
» Replies: 7
» Views: 152
increase in a ratchet-typ...
Last Post:saskak
Today 07:47 PM
» Replies: 5
» Views: 79
Rear hub nut torque setti...
Last Post:geoff
Today 07:31 PM
» Replies: 4
» Views: 80
Heyup
Last Post:polar
Today 07:18 PM
» Replies: 9
» Views: 367
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 580
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 85
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 90
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 879
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 180

Locations of visitors to this page