Thread Rating:
  • 3 Vote(s) - 1.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 2.0 Hdi Siemens lumpy intermittent running
#1
Hello guys,

I'm having slight problems with my 2004 car it's done 130k miles. (14k by me). Was serviced about eight months / 7k miles ago.

It's been getting a bit lumpy.

It began with a slightly rough tickover and occasionally recently refusing to go above 2.5k rpm and this weekend it's now starting to hesitate when the throttle is floored, with a slight momentary rattling sound like 'pinking' and a puff of smoke. As part of my my initial checks, I checked air filter is OK, replaced fuel filter and blanked off egr. The egr blank seemed initially to improve things, but it is probably running rougher now.

Can anyone recommend a reliable independant garage to professionally diagnose and fix it in the Birmingham area?

Also, bit of a complex longshot, has anyone else seen these symptoms and knows what the silver bullet cure is?

Any assistance appreciated, thanks guys.

Seasons greetings! Confusedanta:

Karloff Birmingham
Reply
#2
Have a search on the forum for a member called lighty he is a bit north of you but comes highly recommended.
Have a look at post 15 in this thread.
http://www.berlingoforum.co.uk/showthread.php?tid=8459
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
[+] 1 user says Thank You to Tomcat3 for this post
Reply
#3
Thanks Tomcat I've got his details off the photo...
Reply
#4
I had the same trouble with my berlingo after i blanked the egr off , mine came up with a air flow fault , once i had cleaned the air mass metre and reset the faults and reconnected the egr its been fine ! Touch lots of wood !,,,
[+] 1 user says Thank You to royboy302 for this post
Reply
#5
Thanks Tomcat3. I've got Lighty's details.

Does anyone else know of any other garages closer to Birmingham?

Thanks again.

Karloff

(15-12-2013, 04:05 PM)royboy302 Wrote:  I had the same trouble with my berlingo after i blanked the egr off , mine came up with a air flow fault , once i had cleaned the air mass metre and reset the faults and reconnected the egr its been fine ! Touch lots of wood !,,,

Thanks Royboy, I'll give this a go, cheers!
:S
Reply
#6
There's a bloke in Bilston. I've got his details somewhere. And also a place in Wolverhampton not far from the racecourse, Lion Garage rings a bell but I'll check for you.

Technically Autos Citroen in Bilston. 01902 354 774 Had jobs done here. He's ok but doesn't smile much!

There's also a place in Stirchley/Selly Oak area. The reviews are excellent but never used him. 0121 433 4335

Liontech Garage, Fordhouses, Wolverhampton. Had my Xm serviced and mot there. They're ok. 01902 398766

HTH
Dave.

08 Citroen Berlingo MkIII 1.6 hdi Vtr 90. It's gone. 'Twas a bad'un.

Yes I am an angry old fart.
[+] 1 user says Thank You to demag for this post
Reply
#7
(16-12-2013, 10:14 PM)demag Wrote:  There's a bloke in Bilston. I've got his details somewhere. And also a place in Wolverhampton not far from the racecourse, Lion Garage rings a bell but I'll check for you.

Technically Autos Citroen in Bilston. 01902 354 774 Had jobs done here. He's ok but doesn't smile much!

There's also a place in Stirchley/Selly Oak area. The reviews are excellent but never used him. 0121 433 4335

Liontech Garage, Fordhouses, Wolverhampton. Had my Xm serviced and mot there. They're ok. 01902 398766

HTH

Thanks Dave, I haven't used any of these garages before, I will bear them in mind.

Regards,

Karloff.
Reply
#8
(15-12-2013, 04:05 PM)royboy302 Wrote:  I had the same trouble with my berlingo after i blanked the egr off , mine came up with a air flow fault

The Siemens cars won't run properly with the EGR blanked off. IIRC it's mapped into the ECU, and will throw up the engine warning light and throw it into limp mode. I tried both blanking mine, leaving it unblanked but removing and plugging the vac hose, and blanked with the vac hose blanked. Each time an EML appeared and it went into limp mode.

I sprayed a can of EGR cleaner down it, took it for a good hard drive, and it's been fine ever since.

I suspect the Air Mass Meter is dirty or failing in the OP's vehicle. Cleaning it ( very carefully ) or replacement might resolve the issue.
[+] 1 user says Thank You to mikep1973 for this post
Reply
#9
(26-12-2013, 02:26 PM)mikep1973 Wrote:  
(15-12-2013, 04:05 PM)royboy302 Wrote:  I had the same trouble with my berlingo after i blanked the egr off , mine came up with a air flow fault

The Siemens cars won't run properly with the EGR blanked off. IIRC it's mapped into the ECU, and will throw up the engine warning light and throw it into limp mode. I tried both blanking mine, leaving it unblanked but removing and plugging the vac hose, and blanked with the vac hose blanked. Each time an EML appeared and it went into limp mode.

I sprayed a can of EGR cleaner down it, took it for a good hard drive, and it's been fine ever since.

I suspect the Air Mass Meter is dirty or failing in the OP's vehicle. Cleaning it ( very carefully ) or replacement might resolve the issue.

Thanks MikeP1973. I read your advice today and took out the egr blank and carefully cleaned the Mass air meter with solvent and a toothbrush, even though it was fairly clean anyway. I poured in a bottle of Wynn's diesel tank treatment and sprayed a can of Wynn's egr cleaner into the air intake after the mass air meter as per instructions. But, 300 miles later, still getting the same symptoms.... The check engine light has'nt gone out yet so I think the diagnostic check and fault reset is next priority. There was no change to the engine running after I bypassed the mass air meter, so it needs checking and replacing if required. Thanks again, Karloff.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:Sootyfoot
Today 04:33 PM
» Replies: 10
» Views: 213
HELP! Smashed passenger w...
Last Post:Sootyfoot
Today 04:31 PM
» Replies: 2
» Views: 48
Diagnostic "gear" / Softw...
Last Post:cancunia
Today 04:19 PM
» Replies: 15
» Views: 585
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1011
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 72
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 78
Trip Computer on Type A M...
Last Post:cancunia
Today 09:18 AM
» Replies: 1
» Views: 60
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 111
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 52
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 89

Locations of visitors to this page