Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dashboard backlight
Dashboard backlight
Hello all - Berlingo and forum newbie here.

We just got ourselves a 2007 1.6 HDI 92 Desire. What a great car.

There's something curious about the dashboard backlighting. On key turn all the warning lights show as normal for a few seconds. When they all go out the battery light remains on, but very faintly. When the side lights go on, the same occurs to the brake warning light to the left of battery light. Then, when other lights illuminate, we can just make out the oil light to the right of the battery light. Weirdly, the battery light remains faintly visible even after the car is locked up and the orange digits of the odometer have gone off.

I've checked the brake fluid (normal) and the car starts without any problem. Could this be a simple case of light spillage behind the instrument panel or should I suspect something more sinister?

Also, we're missing a front foglight. Citroen has quoted me a total of £176 for the lamp, the surround, painting the surround and VAT. And that's without fitting it. Anyone know where I can source a cheaper alternative - and are they straightforward to fit?

Cannot be hard to fit if it was already there before going missing ?
Scrapyard or Ebay perhaps for sourcing and the motor factors for a can of paint and clear coat to colour match.
[+] 1 user says Thank You to geoff for this post
Thanks, Geoff - that's what I thought. There are a couple of wires terminating in plugs inside the hole in the bumper, so I'm assuming that the light will have the corresponding sockets. I'm hoping that the surround will then snap on and hold the whole thing in place.
The dash warning light issue sounds like some kind of earthing problem to me. You sometimes see a similar fault in a cars rear light cluster where for example the indicator is switched on and one of the other lights in the cluster flashes in sequence with it.
[+] 2 users say Thank You to stuartinlancashire for this post
Yes, that had occurred to me, too. I'll get it looked at after Xmas. Thanks.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Lexia Mods Please..
Last Post:Trevor
Today 06:16 PM
» Replies: 1
» Views: 28
Front camber out of align...
Last Post:Civvic
Today 05:39 PM
» Replies: 0
» Views: 11
Electrical Fault
Last Post:Civvic
Today 05:11 PM
» Replies: 1
» Views: 55
Last Post:polar
Today 04:44 PM
» Replies: 2
» Views: 46
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 04:41 PM
» Replies: 0
» Views: 29
Diesel fan in Petrol engi...
Last Post:Johny555
Today 10:34 AM
» Replies: 1
» Views: 43
Wanted Berlingo / Partner...
Last Post:b-f-c
Today 08:32 AM
» Replies: 0
» Views: 56
Eco activated but engine ...
Last Post:brajomobil
Today 08:10 AM
» Replies: 13
» Views: 335
WTB Rear Hatch in Silver,...
Last Post:Def-fid
Today 07:56 AM
» Replies: 0
» Views: 33
font fog light bulb chang...
Last Post:Luis Rosa
Today 05:31 AM
» Replies: 2
» Views: 71

Locations of visitors to this page