Thread Rating:
  • 3 Vote(s) - 2.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Non turning over 2.0 HDI
#1
Hopefully someone can help:-
A few days ago went to start my Berlingo and it turned over slowly and wouldn't start, so I used the wifes car to jump start. After connecting the jump leads the Berlingo wouldn't even turn over, so I have charged the battery and still nothing. All I get is a click from the relay on the fuse board. I have tried to reset the BSI but nothing has changed. Today I have put a new battery on and have noticed the dash says that it is in Eco mode and it still wont turn over.
Thanks in advance Mark
Reply
#2
Eco mode doesn't early mean anything bad, it will come out of it once a charging current is received by the battery, ie it starts.
Sounds like your starter motor has failed, one way to find out is to bump start the car, my bet is it will start ok with a push, and then not once switched off.
Reply
#3
(28-12-2013, 05:10 PM)Lighty Wrote:  Eco mode doesn't early mean anything bad, it will come out of it once a charging current is received by the battery, ie it starts.
Sounds like your starter motor has failed, one way to find out is to bump start the car, my bet is it will start ok with a push, and then not once switched off.

Thanks for that i will have to try that tomorrow
[+] 1 user says Thank You to Rabbit73 for this post
Reply
#4
Thanks Lighty,
Have managed to start the Berlingo this morning with a bump start Smile Have taken the starter motor off and given it a test and it is to fault, so it will be a trip to the motor factors tomorrow. Again many thanks Mark
[+] 1 user says Thank You to Rabbit73 for this post
Reply
#5
(29-12-2013, 12:45 PM)Rabbit73 Wrote:  Thanks Lighty,
Have managed to start the Berlingo this morning with a bump start Smile Have taken the starter motor off and given it a test and it is to fault, so it will be a trip to the motor factors tomorrow. Again many thanks Mark

New starter motor now fitted and all up and running, many thanks to Lighty
Reply
#6
Yep! That Lighty's a good man!Confusedalut:Confusedalut:
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Reply
#7
(02-01-2014, 04:41 PM)OlJeffers Wrote:  Yep! That Lighty's a good man!Confusedalut:Confusedalut:

Here here, def a good man Confusedalut:Confusedalut:
A good forum too, now sorted a few little probs out using this site Confusedalut:Confusedalut:
[+] 1 user says Thank You to Rabbit73 for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Running on chip oil
Last Post:polar
Today 04:07 AM
» Replies: 1
» Views: 12
Poor cold startup 1.9
Last Post:Top drive
Today 12:24 AM
» Replies: 40
» Views: 1081
2004 Berlino Aerial
Last Post:brodfather11
Yesterday 10:48 PM
» Replies: 1
» Views: 35
Washers not working
Last Post:Lighty
Yesterday 09:09 PM
» Replies: 11
» Views: 304
Reverse light switch prob...
Last Post:Col
Yesterday 07:22 PM
» Replies: 12
» Views: 263
2005 2.0 HDI Siemens pump...
Last Post:Woodyrvf750
Yesterday 07:05 PM
» Replies: 0
» Views: 32
Fuse is burning all the t...
Last Post:fernandoblas
Yesterday 05:23 PM
» Replies: 12
» Views: 417
HELP! Smashed passenger w...
Last Post:Sootyfoot
Yesterday 04:31 PM
» Replies: 2
» Views: 74
Diagnostic "gear" / Softw...
Last Post:cancunia
Yesterday 04:19 PM
» Replies: 15
» Views: 619
Berlingo Parts
Last Post:malgpz900
Yesterday 10:20 AM
» Replies: 1
» Views: 91

Locations of visitors to this page