Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dash Display
#1
Just been given a 56 plate Berlingo van at work with only 64k on the clock. Quite pleased with it overall but there is a problem with the dash display. I've looked at the handbook and followed the instructions but cannot set the time. Having had a little look on here about this problem, should I disconnect the battery and follow that route or is the display unit knackered. Any advice welcome.
Thanks,
Vince.
Reply
#2
No need to disconnect the battery to adjust the clock!
You use buttons A & B on the face of the display.
Long press on A accesses the menu. Then short presses scroll through the menu.
Five presses scrolls through to hours and six presses gets minutes.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
[+] 1 user says Thank You to Ol'Jeffers for this post
Reply
#3
I was lucky enough to get the manual with the van and have tried doing it the way you describe OJ. No luck :justno: I'm thinking about the battery disconnection or I may just have to accept the display is broken. It is now stuck on German !!
Reply
#4
Have u tried pushing both A and B at the same time for a few seconds? That might do the trick.
[+] 1 user says Thank You to Michel for this post
Reply
#5
Thank you Michael, I will try that.
Reply
#6
Success !! Disconnected the clock today and left it for a few minutes. Then re-connected the plug and hey presto the buttons now work as they should. Thank you all for your advice, I appreciate it.

Vince.
[+] 2 users say Thank You to Vince for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Today 09:04 PM
» Replies: 3
» Views: 49
What website to pass time...
Last Post:Solent
Today 08:32 PM
» Replies: 0
» Views: 21
Berlingo Parts
Last Post:Sb12
Today 07:56 PM
» Replies: 0
» Views: 25
Rear hub nut torque setti...
Last Post:jj9
Today 07:55 PM
» Replies: 15
» Views: 238
temperatue dial
Last Post:Kokain
Today 05:28 PM
» Replies: 3
» Views: 68
Trip Computer on Type A M...
Last Post:cancunia
Today 03:50 PM
» Replies: 0
» Views: 23
Loud beeping from radio u...
Last Post:nicko
Today 03:49 PM
» Replies: 3
» Views: 110
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 468
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 74
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 229

Locations of visitors to this page