Thread Rating:
  • 37 Vote(s) - 2.92 Average
  • 1
  • 2
  • 3
  • 4
  • 5
heavy clutch
#1
Hi
I brought a 2003 HDi 2l diesel last month, my parents test drove it and collected it, i never drove it before it was brought as it was brough up north and i live in the SW

I find the clutch really heavey and it bites very low down. I have driven other diesels vehicles before cars, vans, pick up land rovers and never had this problem.

Basically when i pull off in 1st i dont need to press accelorator at all on the flat and it races away at 5+ mph. It stalls if there is a gradient when i have to use a bit of accelorator. I know diesels have a bit of creep, but these a bit too muchRolleyes. I drove a belingo as a hire car 5 yrs ago and didnt have a problem then.

Also there is a slight intermiting juddering when in nuetral

Is this the norm? There are other niggly problems for another threadConfusedideon:

Reply
#2
Where in the S.W. are you?
Reply
#3
(16-06-2011, 07:27 AM)Coco Wrote:  Where in the S.W. are you?

somerset
Reply
#4
Personally I found both my bingos bite low down even after replacing the clutch on one of them. I find you really need to makes sure the pedal goes right down. Are sure its a heavy clutch? the cables have a habit of becoming very stiff and you may find a few quid on a cable will make a noticeable difference.

Sent from my GT-I9000 using Tapatalk
1.9d Mk2 (M59/BE4/5) with battle scars from a conservatory attack. Previously owned a 1.4i Mk2 Forte.Confusedalut:
[+] 1 user says Thank You to divingscubaboy for this post
Reply
#5
(15-06-2011, 08:45 PM)mar mite Wrote:  Hi
I find the clutch really heavey and it bites very low down. I have driven other diesels vehicles before cars, vans, pick up land rovers and never had this problem.

Before to replace clutch kit, replace clutch cable.
Reply
#6
Same on mine, 2.0hdi. Thinks its probably because we are used to hydraulic clutches these days, so when you get into one with a cable operated clutch it feels heavy
Reply
#7
(19-06-2011, 01:12 PM)800HDI Wrote:  Same on mine, 2.0hdi. Thinks its probably because we are used to hydraulic clutches these days, so when you get into one with a cable operated clutch it feels heavy

This is what I've told my wife, she's struggling with the heavy clutch on the berlingo, our 2 pug coupes are both hydraulic clutches so light as a feather. Is there an adjustment for the clutch cable on the berlingo? Our clutch is brand new, but theres some play at thw top of the pedal travel before you feel it start to move the clutch plates.
Reply
#8
Did you renew the cable with the clutch. The cables have an adjuster built in which is non serviceable. Also check the routing is correct. There is a plastic spring assembly on the pedal inside the vehicle, its worth lubricating it. Careful not to lubricate the pedal rubbers though!

Sent from 2 bean tins and a piece of string!
1.9d Mk2 (M59/BE4/5) with battle scars from a conservatory attack. Previously owned a 1.4i Mk2 Forte.Confusedalut:
[+] 1 user says Thank You to divingscubaboy for this post
Reply
#9
I think the heavy clutch is par for the course with these. I've got used to it, but it's always murder driving my car after I've had a company car for a day as it feels even heavier afterwards.
2000/X Peugeot 406 110 HDi LX Family 93k to 2000/W BMW 530D SE Auto 84k to 2003/03 Peugeot Partner Escapade 95k

Standard so far

[Image: Signature.jpg]
Reply
#10
(13-12-2012, 04:56 PM)divingscubaboy Wrote:  Did you renew the cable with the clutch. The cables have an adjuster built in which is non serviceable. Also check the routing is correct. There is a plastic spring assembly on the pedal inside the vehicle, its worth lubricating it. Careful not to lubricate the pedal rubbers though!

Sent from 2 bean tins and a piece of string!

Thanks, i shall check inside the car, the cable looks new from when i was undernath changing the oil, i didn't change the clutch myself, some garage did for the previous owner, they did leave the bottom LH engine mount loose though!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Reverse light switch prob...
Last Post:willpisme
Today 08:09 PM
» Replies: 7
» Views: 138
increase in a ratchet-typ...
Last Post:saskak
Today 07:47 PM
» Replies: 5
» Views: 71
Rear hub nut torque setti...
Last Post:geoff
Today 07:31 PM
» Replies: 4
» Views: 75
Heyup
Last Post:polar
Today 07:18 PM
» Replies: 9
» Views: 365
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 569
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 84
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 88
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 878
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 179
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 60

Locations of visitors to this page