Thread Rating:
  • 7 Vote(s) - 3.29 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I have a Mk2 Berlingo desire. I get a click from under the dash when I turn the key to start, but that's all. Also: my windscreen wipers, blower, headlights, heated rear window are not interested in coming out to play. It seems to point to bsi unit I'm thinking.... Have tried the reset tests suggested but no avail. Have gone through fuses, all ok, also I tried taking out the shunt fuse and then putting it back, windscreen wipers wiped once and then parked. Clutching at straws and possible solutions now.

Looking at earlier forums, rustscrat seems like the wizard of berlingoland, I hope you're out there Mister R

Many t[/align]hanks
je regrette rien
Does anything light up on the dash, mileage/air bag checks etc?
Has this fault just appeared or have you just bought it with this fault.
Have you looked for possible water ingress in the Bsi?
What does the radio display say when you switch on the ignition? :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Hi Rustscrat, good to hear from you!

I've had the car a few months, as far as I know all dash lights come on and nothing unusual, no warnings etc. Interface thingy says ECO MOD though, don't know if this is a new thing as it is fairly dim and dont normally look at it, or if has any relevance to the fault.
Can't see any signs of water ingress on BSI, it looks really dry, but only looking at it in situ. Don't have original radio, it came with a replacement one.....
je regrette rien
Because it's in "economy mode" you won't get anything else to work until the engine starts and resets this.
If your van has the same start circuit as most others the engine should still turn over with the key regardless of the immobilizer etc. It just won't fire up. If you want to be sure, P/mail me your Vin No. and I'll check the drawings.
Sounds to be a starter motor/solenoid problem. :thumbsup:
2006 2.0hdi 600 with bench seat.  Cool
Yep, the solenoid power comes from the ignition switch, goes into the Psf (engine bay fuse box) on the 16 way plug "PP2", then straight back out on the 2 way plug "Bat Noir" then to the solenoid on your starter. Should be simple to check if you have a meter of some kind. Confusedalut:

2006 2.0hdi 600 with bench seat.  Cool
Started car ok by a quick tow, which was a relief. Getting an odd whine sound as it runs, I drove through a partly flooded road last week, not madly deep but wet enough to throw water around. I'm wondering if the water would have affected the alternator and it's output?
je regrette rien
Put a tester across your battery with the engine running and the alternator should be putting about 14v into it. Usually when you are getting clicks and not starting if the battery is not flat it is down to a bad earth either on the battery terminal to body or the engine to body.
So where does this bit go then ?
Thanks ffrenchie
Will give that a go, wondering what the 'whine' thing is...
Hopefully a dry spell will appear this week and I can get down and dirty with my berlingo properly
je regrette rien
I bought a 2003 Berlingo multispace on Monday and today, Thursday it wont start and I have lights - STOP and various, plus lights coming on with key out etc. I have read the various posts, but I am a 51 year old disabled lady who doesn't know where to start Sad I spent the money I have on the Berlingo, and I don't have much left for garage repairs.
The history with the vehicle says it had two NEW BSI units - 2008 and 2010. Do you think I will need another? Your advice would be welcome!
Thank you:brickwall:
Bump..... :wave:

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
P1351 fault code.
Last Post:brajomobil
Today 06:41 AM
» Replies: 15
» Views: 823
Dead BSI unit?
Last Post:brajomobil
Today 06:26 AM
» Replies: 3
» Views: 38
2012 berlingo radio setti...
Last Post:NANO_Vigo
Today 02:19 AM
» Replies: 10
» Views: 212
Black Smoke
Last Post:Jed Clampit
Yesterday 10:07 PM
» Replies: 3
» Views: 91
Strange exhaust blowing n...
Last Post:dieselj
Yesterday 10:00 PM
» Replies: 1
» Views: 41
My Berlingo Camper build....
Last Post:Jed Clampit
Yesterday 09:58 PM
» Replies: 8
» Views: 358
DPF Regeneration
Last Post:Jed Clampit
Yesterday 09:46 PM
» Replies: 4
» Views: 75
New Battery
Last Post:Jed Clampit
Yesterday 09:35 PM
» Replies: 3
» Views: 68
Window mechanism replacem...
Last Post:Kez
Yesterday 09:01 PM
» Replies: 2
» Views: 65
Air Vent Directors Loose
Last Post:doofer
Yesterday 08:19 PM
» Replies: 2
» Views: 203

Locations of visitors to this page