Thread Rating:
  • 4 Vote(s) - 2.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cable clutch mk 1 berlingo
#1
took my x reg berlingo on a 320 mile round trip about 80 miles in found it near impossible to select first and was forcing in 2nd to move off after doing 200 miles and when I reached my destination I pushed the clutch all the way down then it sprang back and I had a clutch pedal level with the brake again and could easily select all gears

Anyone know what's wrong??
Reply
#2
My first guess would be sticking clutch cable/linkage
Landmark
Ex 1.4 Berlingo Multispace
Reply
#3
its an lpg van runs well on gas. Trying to work out what kinda mpg I'm getting should be saving 40 % of what I get on petrol
Reply
#4
Check the auto adjuster.Confusedalut:
Strawberry flavoured windows  Dodgy
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Saying Hello
Last Post:Bazzingo
Today 09:07 PM
» Replies: 0
» Views: 14
1.6 hdi 90bhp Turbo and i...
Last Post:Floydster
Today 07:48 PM
» Replies: 3
» Views: 135
1.6 16v petrol cambelt
Last Post:sks01773
Today 07:37 PM
» Replies: 12
» Views: 250
Heated wing mirrors
Last Post:Trevor
Today 07:06 PM
» Replies: 3
» Views: 82
2025 Diesel Ban
Last Post:Tree
Today 06:17 PM
» Replies: 15
» Views: 344
Hello
Last Post:Johny555
Today 06:04 PM
» Replies: 1
» Views: 19
Roof noise
Last Post:Veitcast
Today 05:48 PM
» Replies: 0
» Views: 28
Fuel consumption
Last Post:Opensauce
Today 05:37 PM
» Replies: 3
» Views: 53
Lexia clone that works wi...
Last Post:kennard
Today 02:59 PM
» Replies: 58
» Views: 1840
Insurance!
Last Post:Opensauce
Today 01:52 PM
» Replies: 10
» Views: 925

Locations of visitors to this page