Thread Rating:
  • 4 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] ECU, sensor, wiring??
Hello all,
I'm having problems with my 2.0hdi multispace 04 reg. First fault, engine stalled and failed to start, diagnosed as engine speed sensor. Replace and ran for approx. 4 wks. Same fault, this time crankshaft sensor, replace and ran for another few weeks. Same fault again, this time sent ecu away for checking, no faults found. Garage had car for 2 wks of testing, they also checked
ecu, no faults found. Finally replaced ecu with another unit. Car ran for another few wks. Same fault, another cam shaft sensor replaced. Car ran for a wk, same fault! I have no hair or money left! Any ideas?
I would check the engine wiring from the sensors and to the ECU for splits or chafing especially where it is near to the engine and check for poor connections. Very frustrating.
[+] 1 user says Thank You to JohnM for this post
Agree!! A damaged wiring harness will give you random faults.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
First things first. I'd check the alternator and battery, you need to load test the battery for proper information on its health. The alternator has to have its output assessed by looking at the voltage "wave" as a blown rectifier diode or faulty regulator will give an ECU pink fits.

When you know the voltage supplies are good and steady, some time with a "Lexia" factory diagnostic tool is the safe option. Also, if you test all the engine harness with a multimeter you may find damage from crushing or corrosion. Some motors do sneaky things like push antifreeze up the wires so the ECU rots internally.
[+] 1 user says Thank You to addo for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Last Post:Jane Rushby
Today 08:43 PM
» Replies: 3
» Views: 35
Eco activated but engine ...
Last Post:Lighty
Today 08:05 PM
» Replies: 17
» Views: 387
Roof bars for VTR?
Last Post:Jed Clampit
Today 07:57 PM
» Replies: 1
» Views: 21
M49 Budget DIY Camper con...
Last Post:Jed Clampit
Today 07:42 PM
» Replies: 21
» Views: 2274
Upgrading DAB radio recep...
Last Post:Multispacer
Today 07:39 PM
» Replies: 13
» Views: 2445
Berlingo VTR to ''XTR'' l...
Last Post:Multispacer
Today 07:17 PM
» Replies: 5
» Views: 200
Faulty Radio unit [or not...
Last Post:Multispacer
Today 07:13 PM
» Replies: 1
» Views: 223
Front camber out of align...
Last Post:polar
Today 07:02 PM
» Replies: 7
» Views: 102
Grinding noise when steer...
Last Post:tanto
Today 05:36 PM
» Replies: 1
» Views: 106
font fog light bulb chang...
Last Post:rdfb2
Today 05:11 PM
» Replies: 4
» Views: 105

Locations of visitors to this page