Thread Rating:
  • 4 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] ECU, sensor, wiring??
#1
Hello all,
I'm having problems with my 2.0hdi multispace 04 reg. First fault, engine stalled and failed to start, diagnosed as engine speed sensor. Replace and ran for approx. 4 wks. Same fault, this time crankshaft sensor, replace and ran for another few weeks. Same fault again, this time sent ecu away for checking, no faults found. Garage had car for 2 wks of testing, they also checked
ecu, no faults found. Finally replaced ecu with another unit. Car ran for another few wks. Same fault, another cam shaft sensor replaced. Car ran for a wk, same fault! I have no hair or money left! Any ideas?
Reply
#2
I would check the engine wiring from the sensors and to the ECU for splits or chafing especially where it is near to the engine and check for poor connections. Very frustrating.
[+] 1 user says Thank You to JohnM for this post
Reply
#3
Agree!! A damaged wiring harness will give you random faults.
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
Reply
#4
First things first. I'd check the alternator and battery, you need to load test the battery for proper information on its health. The alternator has to have its output assessed by looking at the voltage "wave" as a blown rectifier diode or faulty regulator will give an ECU pink fits.

When you know the voltage supplies are good and steady, some time with a "Lexia" factory diagnostic tool is the safe option. Also, if you test all the engine harness with a multimeter you may find damage from crushing or corrosion. Some motors do sneaky things like push antifreeze up the wires so the ECU rots internally.
[+] 1 user says Thank You to addo for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
increase in a ratchet-typ...
Last Post:saskak
Today 05:31 PM
» Replies: 3
» Views: 49
New owner
Last Post:SheilaAnn
Today 04:33 PM
» Replies: 12
» Views: 558
Repair a manual winder wi...
Last Post:Col
Today 04:26 PM
» Replies: 3
» Views: 76
2-Button Key Upgrade
Last Post:Mojow Royle
Today 02:52 PM
» Replies: 1
» Views: 83
Heyup
Last Post:Mojow Royle
Today 02:49 PM
» Replies: 8
» Views: 354
Poor cold startup 1.9
Last Post:Top drive
Today 02:46 PM
» Replies: 36
» Views: 872
Rear hub nut torque setti...
Last Post:El Berlingo
Today 01:14 PM
» Replies: 3
» Views: 67
peugeot charger
Last Post:Jed Clampit
Yesterday 11:28 PM
» Replies: 5
» Views: 177
hello
Last Post:Jed Clampit
Yesterday 11:16 PM
» Replies: 2
» Views: 59
XTR heater control bulb r...
Last Post:VicG
Yesterday 10:57 PM
» Replies: 0
» Views: 43

Locations of visitors to this page