Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] Hdi still randomly not starting *filter?
As per when I posted a while back my HDi is still randomly not starting hope no one minds but started a new post becouse I think I have narrowed the problem down and I need your help :-).

I noticed when it refuses to start the clear plastic pipes from the primer bulb and the filter to the pump are 1/2 Diesel 1/2 air and when cranking no fuel is going through.

Im sure its airlocking if I primed the bulb to the filter it seemed totally locked up then it would weep fuel from the filter seal so I tightened it and the car run fine for a week with no bubbles in the clear pipes.

Last night it refused to start again no matter what so this morning I have fitted a new filter and seal and eventually got the air out of the pipes and its running great however if I stop the engine and prime the bulb its still weeping fuel at the diesel filter seal do they all do this as I suppose something has to give Undecided

Failing that could it be the plastic top itself thats warped or not sealing correctly?
It shouldn't weep from the housing. Does sound like it or its lid might be distorted. For info: pretty sure all my hdis have had the odd air bubble in the transparent pipe from the priming bulb although never affected starting.
If your filter housing leaks diesel under pressure it must be pulling in air when under vacuum. Can you get hold of another housing from a scrapper or get a new one? Good luck!
Cheers for replying,

I have been keeping my eye on it and the seal is a lot better at the moment but If I rev the car whilst under the bonnet the only pipe that you can see air bubbles is the clear one from the filter to the pump .i.e the more revs the more air heading into pump so as you say the filter housing maybe distorted. When I get chance I will get to scrappers and remove the whole assembly including pipes :-)
Just thought it was worth updating this, Since tightening the fuel filter housing up tight with a filter wrench it start fine now

Sent from my C6903 using Tapatalk
Job done!

Glad it turned out to be a simple fix for you
(24-04-2014, 11:49 AM)homeruk Wrote:  Job done!

Glad it turned out to be a simple fix for you

For future reference if you have a suspected air ingress simply use a dollop of " Plasticine " around the joint to temporarily seal it off, quick and easy diagnosis. Having children or grandchildren around does have its benefits after all.


Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 94
Injectors and B9 series.....
Last Post:peecee2
Yesterday 10:31 PM
» Replies: 0
» Views: 18
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 240
Bump and Run - Am I right...
Last Post:Jed Clampit
Yesterday 10:13 PM
» Replies: 11
» Views: 146
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 133
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 68
Dead BSI unit?
Last Post:Kez
Yesterday 07:22 PM
» Replies: 4
» Views: 107
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 196
replacing diesel fuel pip...
Last Post:geoff
Yesterday 05:13 PM
» Replies: 35
» Views: 2009
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Yesterday 04:57 PM
» Replies: 0
» Views: 29

Locations of visitors to this page