Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Exhaust causing poor running?
My wifes berlingo has been having trouble.

I had air in the fuel to the inj pump caused by a bad priming pump, fitting a new filter housing has sorted this, now the car drives and you can accelerate full throttle no problem.

However at mid throttle accelerating the engine smokes and the engine power sort of pulses, as though you were pressing and releasing the throttle pedal to the floor.

I noticed that the exhaust connection from the front box to the inlet of the cat is leaking, theres carbon around this area, the front box was changed in dec so the mrs had taken it back to that garage this am.

Would a bad exhaust connection cause the engine to surge?, I know it could be the cause of the smoke, these problems started when the new exhaust was fitted.

I was thinking maybe the crank sensor was bad, however I have a obd2 interface and plugged it in last night, I get 1115 rpm which tells me the crank sensor is ok as this is where the rpm calc comes from, its also shows me engine loading which comes from the pump, and engine coolant temp, so electrically it seems ok.
Is the air filter OK?You can try running Forte or Millers through it.It will at least clean the system & @ best cure the prob.Confusedalut::thumbsup:
Strawberry flavoured windows  Dodgy
[+] 1 user says Thank You to ron for this post
An exhaust can cause poor running if its blocked
I had made the assumption the air filter was ok, as this problem started when the exhaust was changed, however if it comes back with the exhaust fixed and it still does it I'll pull it and check it, maybe try it without it.
Is millers an injector cleaner?
Yes Millers is a system cleaner. Personally I use Forte in my Land Rover. Just add to fuel.
Ex 1.4 Berlingo Multispace
Ok then thanks.

The berlingo has been at the garage 2 days now, we returned it as they fitted the suspect exhaust.
Yesterday they did confirm that the exhaust is the problem, didnt say anymore than that, I suspect they took it off and went round the yard without and it ran ok.

I bought the exhaust from a local factors only a few weeks back, so I'll take it back and get a credit if it turns out to be that.
Now sorted.

It was a damaged cat causing a restriction in the exhaust.

The cat has been cut open the brick removed and welded shut, the car runs miles better and will be more economical, and the garage says they will still pass its mot as far as the cats concerned.
[+] 1 user says Thank You to dr peppers for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Lack of power Then surge ...
Last Post:michaelg
Today 10:34 PM
» Replies: 6
» Views: 197
something new
Last Post:Matt Haigh
Today 10:26 PM
» Replies: 1
» Views: 44
Last Post:ntm1275
Today 09:51 PM
» Replies: 2
» Views: 67
Last Post:ron
Today 07:46 PM
» Replies: 6
» Views: 144
Poor fuel economy.. again...
Last Post:Jane Rushby
Today 06:50 PM
» Replies: 13
» Views: 1409
Where Did you find
Last Post:Jane Rushby
Today 06:26 PM
» Replies: 93
» Views: 165494
Radio needs VIN programme
Last Post:Tomcat3
Today 06:09 PM
» Replies: 3
» Views: 137
Speedo/milometer fault
Last Post:Gixxerguyk8
Today 04:51 PM
» Replies: 10
» Views: 908
Rear reversing sensors
Last Post:tarrymittens
Today 03:55 PM
» Replies: 0
» Views: 37
Heater Matrix replacement...
Last Post:noworries81
Today 01:13 PM
» Replies: 22
» Views: 3751

Locations of visitors to this page