Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Steering & Suspension] Pulling left
I bought a new berlingo 3 weeks ago, when driving it keeps pulling left. Anyone experience this problem? Any advice on getting it repaired. Thanks
Since it's a new auto I'd head straight back to the dealer and tell him to sort it.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Have you checked the tyre pressures , I found all of mine were under inflated causing pitching and rolling .
Two front at 32 psi
Yes, I had the same problem. First step was to make sure all the tyre pressures were correct, that made things much better, though still not quite right. At the next service (at an independent Citroen specialist) had the tracking checked which was ok, but they swapped the wheels around which further improved things so that its just about ok now.
Same problem for posted a thread, mine 2012 going back AGAIN next week full system test with Citreon has they can't sort it at the garage tracking issues. You are in a long stressful time I'm handing mine back once term is up!!
I find to resolve mine by changing the steel wheel to the rear. Ideally I should replace it as sometimes I forget and put it back in the front. It's not a big deal.
just on the subject of the berlingo pulling to the left my father in law bought a new mercedes which pulled to the left, after countless trips back to the dealer he went to an independent and they said it pulled to the left due to the geometry being set up for the roads on the continent. He got it finally got it sorted by the main dealer fitting a small kit to the suspension to correct the geometry. Would this be the same case for the berlingos that most seem to pull to the left?
#13 Less than 1 minute ago
Email he doing a program on these issues, don't get done get Dom, citroen say they have never heard or recieved any complaints but this forum has highlighted them, some cases are worse than others.
Mine tends to pull slightly to the left & when I drive in Europe it tends to pull slightly to the right so I guess its just running down the camber.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
2004 2.0HDi Cruise Contro...
Last Post:cancunia
Today 05:37 PM
» Replies: 2
» Views: 76
Still on the elusive 4x10...
Last Post:Carl Davis Hulin
Today 05:00 PM
» Replies: 4
» Views: 155
Bump and Run - Am I right...
Last Post:Opensauce
Today 03:19 PM
» Replies: 18
» Views: 288
Eco activated but engine ...
Last Post:Satellitemark
Today 02:57 PM
» Replies: 28
» Views: 795
I'm hearing better or smt...
Last Post:Johny555
Today 02:05 PM
» Replies: 10
» Views: 351
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 25
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 153
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2063
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 147
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 70

Locations of visitors to this page