Thread Rating:
  • 7 Vote(s) - 3.57 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] 1.9 DW8 Fuel Pump Replacement woes, please help fix this!
#1
1.9 DW8 Fuel Pump Replacement woes, please help fix this!

:wave: Hello all,

I'm hoping somebody here can help me, so I can get this sorted out, as its been in a garage for 7 weeks now! :eek::brickwall::brickwall:

Mothers MK1 51 plated Berlingo Multispace 1.9d DW8 with 95k ish miles.

Was running rough intermittantly, did alot of research and did the following:
-Removed EGR. (nothing changed)
-Checked wiring to the few sensors. (all ok)
-Replaced Advance Solenoid. (nothing changed)
-Removed particle filter/cat incase it was blocked.(nothing changed)
-Full Service. (nothing changed)
-I then think its got to be either the Injector with the wiring, or the pump itself.

She decided to take it to a local garage:-
-Compression low on 2 & 4.
-Head was removed and checked.
-New head gasket, timing belt (still runs the same...)
-Fitted a new injector (still runs the same...)
-They have a specialist down the road have a look at it, and apparently they had it running normally for a while then it reverted back to running like a sack. Their diagnosis is Fuel Pump (which funnily enough was mine too....)


Anyway, the garage have been told to find a used working pump and fit it, they have spent 2 1/2 weeks looking and cannot find one, claiming the ones they have found won't work.

The pump is a Lucas Delphi R8448317B pump, also states 231089FVF on the sticker too.

I have found a couple of pumps with the first part number on ebay, but the second numbers do not match.

As far as I am aware, as long as we get old of the same type of pump, we can swap over the immobiliser from the old pump, onto the new pump.. and this should work??
As the garage seem to think this will not work...

If you can swap the immobiliser over to enable a used pump to work correctly, this will solve all the problems as I will instruct them to pull their finger out!

Many thanks to anybody that may read this, and help.

Thanks, Paul.
Reply
#2
Is their still low compression on 2 & 4 and were valve clearances checked?
Reply
#3
I agree with the above the valve clearances should be one of the first things to be checked when experiencing rough running or cold start problems.

1.9d valve clearances should be:
exhaust: 0.30mm
inlet: 0.15mm

I'm sure you'll find your problem here! Smile
Adam..2003..1.9D..LX..Silver Crew Cab Van.....
If at first you don't succeed, destroy all evidence that you tried.
Reply
#4
If low compression has been identified, the first check for the cause is normally valve clearances. I wouldn't be surprised if they are closed up at 95k. Equally I would be surprised if the pump had failed.

Have you got a diesel specialist looking at it? I'd suggest they'd find it quite quickly rather than playing parts bingo.
Reply
#5
Hi guys, thankyou for the replies!

Apparentlythe compression was tested with the head back on and it was fine..
And it was a diesel specialist down the road from them which looked at the pump and determined it was that which was the problem. It was running fine for a while with them, then went back to running rough.

I would check the clearances of the valves myself if I had access to the van, but as its at the garage I am abit stuck.
I would take it off them and tell them to shove the bill for what they have done so far, but as she is currently using their courtesy car for work, a non working berlingo would mean she cant get to work and back Sad

Am I being stupid here, but if the valve clearances were an issue, wouldn't it run rough all the time? As this is intermittent, and doesn't have any issues with starting in the cold either.

This is the reason why I always fix my own cars, garages are mostly crap unless they can plug it into a machine!

Many thanks, Paul.
Reply
#6
If the valve clearances were out it would be constant, but because you'd mentioned low compression and hadn't mentioned they were checked. It needs to be ruled out as it's an easy one. I would still want to know they have actually been measured and what they were measured at.

If there was low compression and now there isn't, what is the explanation? Did they notice head gasket failure when they had the head off??

I didn't think you needed the exact pump, see:

http://306oc.co.uk/forum/thread-23185.html

but then I presume this is DW8B with some electronics yes?
Reply
#7
Fair enough cheers!

They claimed they saw point on the headgasket when they took it off, and they sent the head to the diesel specialist to rule out valves. But this was via a phone convo to my mother, then passed on to me so I really do need to have a word about exactly what they have done!

Yeah its the DW8 with an ecu which controls the advance solenoid on the pump, with a sensor on one of the injectors (and a disabled egr system)

As far as I can tell, I can get any dw8 pump and either swap the immobiliser solenoid over, or fit a simple 12v wired stop solenoid which in turn disables the immobilsor function.... But telling this to the garage feels like talking to a brick wall!

If it were mine I would have dropped in a phase 1 306 d turbo lump with no electronics, simple!

Cheers, Paul.
Reply
#8
Im running an M59 55 plate DW8 fitted with an early 90's Pug 306 injection pump, with the immobiliser block ground off and replaced with a normal stop start solenoid, so a pump swap out is very do-able...
[+] 1 user says Thank You to ulysses for this post
Reply
#9
(29-04-2014, 05:11 PM)ulysses Wrote:  Im running an M59 55 plate DW8 fitted with an early 90's Pug 306 injection pump, with the immobiliser block ground off and replaced with a normal stop start solenoid, so a pump swap out is very do-able...


Spot on thanks.

I might be able to get hold of a Pug 206 pump, same DW8 engine with electronics, last few digits on pump code are different, but as far as I can tell, I will be able to fit the berlingo solenoid over.. Or as you say, fit a normal stop start one in its place!

If I can get it cheap its worth trying!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Haynes manuals - which on...
Last Post:jj9
Today 10:08 AM
» Replies: 1
» Views: 14
Fuel flap
Last Post:3rensho
Today 10:01 AM
» Replies: 1
» Views: 14
2.0 HDi fuel issues as pe...
Last Post:G.mk3
Today 10:01 AM
» Replies: 9
» Views: 159
Poor cold starting. Whats...
Last Post:geoff
Today 09:18 AM
» Replies: 10
» Views: 158
lubricating door
Last Post:ghost123uk
Today 09:13 AM
» Replies: 7
» Views: 157
Heyup
Last Post:Mojow Royle
Today 09:06 AM
» Replies: 5
» Views: 247
2012 enterprise berlingo ...
Last Post:Top drive
Today 06:57 AM
» Replies: 10
» Views: 269
Rear light Cluster
Last Post:Jed Clampit
Yesterday 09:52 PM
» Replies: 6
» Views: 142
1.6 16v petrol cambelt
Last Post:sks01773
Yesterday 07:27 PM
» Replies: 16
» Views: 388
Roof noise
Last Post:Opensauce
Yesterday 06:39 PM
» Replies: 5
» Views: 142

Locations of visitors to this page