Thread Rating:
  • 3 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Off side brake light problem
My offside brake light not illuminating .Nearside and high level lights working fine .Checked bulb and fuse both fine .Any suggestions ?Sad
[+] 1 user says Thank You to Susan Mayer for this post
hi susan,, more than likely in the connector block behind light cluster,,, check connections,, and check for bad earth,, if you have a multimeter check for power and earth,, if not, get a piece of wire direct from battery and try power,, then earth,, you will find where prob is
Hi will try that ,thanks for the advice
Welcome Susan! Hope you manage to sort that out!
[fon‌t=Tahoma, Calibri, Verdana, Geneva, sans-serif]The Older I get the Better I Was!  Cool [/font]
The offside position light ,indicator and fog light illuminate too, just the brake light doesn't
could be a bad connection at the bulb source,, or in the connector block,, you need to check if you have 12 volts at the connection to the bulb
I was following a van the other day with an earth problem. Indicating left was fine till he pressed the brake then all the other lights went out and just the brake light was left on flashing. It looked like one of those old American cars where the brake light doubled as indicator.
So where does this bit go then ?
Hi thanks for everyone's assistance , it was a connector fault which I have now rectified :-)
[+] 2 users say Thank You to Susan Mayer for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 84
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 262
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 503
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 236
My Berlingo Camper build....
Last Post:knownowt
Yesterday 06:40 PM
» Replies: 5
» Views: 285
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 768
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2517
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17324
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 89
Speedo light not working?
Last Post:brodfather11
Yesterday 04:11 PM
» Replies: 1
» Views: 41

Locations of visitors to this page