Thread Rating:
  • 4 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Berlingo 2.0 HDI (2005) Cold Starting Issues
#1
Hello
We have a problem with cold starting:
The glow plug indicator o the dash doesn't come on;
Solenoid doesn't click (solenoid is replaced with new);
No power to glow plugs (which have been replaced with new);
Fuses are all OK
Vehicle starts after prolonged churning of starter motor
We have tried putting 12 V directly to the glow plugs but although they seem fine and are drawing current the engine is still very slow to start.

Once warm the engine will start perfectly all day long, but the next day

Any ideas out there??:S
Reply
#2
Hdi motors do not need glow plugs to start unless the temp goes below @-4 degrees, so forget that.
Obviously I have not seen your car, but the most common issue on the hdi is slow cranking speed, ie poor battery or most likely lazy starter motor.
The engine needs to spin quickly , ie about 300 rpm to make enough rail pressure to fire the injectors. If it's less they simply will not work.
Reply
#3
Hi,
I have had problems with my Berlingo 2.0Hdi for the last twelve months or so. It never failed to start, even on very cold days but would crank for 20 to 30 seconds on first start of the day and was ok for the rest of the day.  
It has been to 3 garages and they had told me that the glow plugs were not working, the relay needed replacing, the temperature sensor was faulty and lastly the engine management unit needed replacing (£800) all using their diagnostic computer. All giving the wrong diagnosis. All these parts were working perfect.
The starter motor was the problem, it got lazy, as Lighty says it needs to crank the engine above a certain speed for the injectors to fire and the compression to generate temperature in the cylinders (compression ignition). The cost of replacing the starter motor was £82.00 plus vat and one hours labour.
Tongue I'm a Happy bunny now
Hope this helps others with the same problem.
Reply
#4
I have a 2004 2.0hdi. The glow plug light very rarely illuminates, then only for half a second on very cold mornings.
I wouldn't be surprised if it's your starter motor as mentioned above.
I had cold cranking problems, starter wouldn't spin engine fast enough and would kill the battery, so got one of these:
http://www.ebay.co.uk/itm/CITROEN-BERLIN...SwirZTtAGU
Never a problem since.
Reply
#5
I've checked ours a few times and the glow plug light comes on at 2°c and under. I found that if I switch the ignition on then fit my seatbelt before turning the key to start the car it turns over faster than if I just get in and wind it straight over. It's as if the car cuts power to the electrics when it is first switched on.
So where does this bit go then ?
Reply
#6
Got same problems with mine.auto election reckons no feed to glow plugs.I tried telling him they don't come on till its really cold.but he said should still be feed their he wanted to put a separate switch direct to glow plugs.? But I've read loads on here and it always goes back to getting a new starter motor.witch way do I go??? New starter or a switch to glow plugs???
Reply
#7
Assuming battery OK, and it's not turning very fast- New starter (and a new auto electrician)
Reply
#8
(28-01-2016, 06:18 PM)Col Wrote:  Assuming battery OK, and it's not turning very fast- New starter (and a new auto electrician)

That's what I keep thinking. Get a new starter.turns a bit slower when its cold.but then its fine all day long..
Reply
#9
Thumbs up for a new starter to.
Are we there yet????? No we fecking ain`t  gggggrrrrrrr
Ex 1.6hdi van now 3 seater 1.4 multispace
Reply
#10
(28-01-2016, 06:23 PM)Johny555 Wrote:  
(28-01-2016, 06:18 PM)Col Wrote:  Assuming battery OK, and it's not turning very fast- New starter (and a new auto electrician)

That's what I keep thinking. Get a new starter.turns a bit slower when its cold.but then its fine all day long..

When cold, does yours actually start eventually or does the battery die first?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold startup 1.9
Last Post:Top drive
Today 02:01 PM
» Replies: 38
» Views: 1002
HELP! Smashed passenger w...
Last Post:divingdad
Today 01:35 PM
» Replies: 1
» Views: 29
Reverse light switch prob...
Last Post:Sootyfoot
Today 12:32 PM
» Replies: 8
» Views: 187
Berlingo Parts
Last Post:malgpz900
Today 10:20 AM
» Replies: 1
» Views: 64
XTR heater control bulb r...
Last Post:Opensauce
Today 09:19 AM
» Replies: 1
» Views: 75
Trip Computer on Type A M...
Last Post:cancunia
Today 09:18 AM
» Replies: 1
» Views: 56
DW8 engine tapping
Last Post:jj9
Today 01:14 AM
» Replies: 3
» Views: 109
Rear window heater repair
Last Post:Silverberlingo
Yesterday 11:38 PM
» Replies: 0
» Views: 47
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Yesterday 09:04 PM
» Replies: 3
» Views: 82
What website to pass time...
Last Post:Solent
Yesterday 08:32 PM
» Replies: 0
» Views: 61

Locations of visitors to this page