Thread Rating:
  • 4 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electric Window
#1
Hi guys, my 08 berlingo drivers electric window was a little funny lately (going down when i push up on the switch), and eventually stopped. Replace the regulator inc motor and worked OK for a day or 2, now it went down today and will not come back up!. I hear the motor click like its trying to lift but it dosent!. Any ideas?
Thanks
Reply
#2
Update,changed the switches and drivers window will still no go up


Sent from my iPhone using Tapatalk
[+] 1 user says Thank You to kierc0857 for this post
Reply
#3
Thanks guys!


Sent from my iPhone using Tapatalk
Reply
#4
Does the glass slide freely?

Can you operate it with Lexia or another comprehensive scan tool that "test fires" body equipment?
Reply
#5
Glass stays down,new regulator fitted but all infernos a clicking of the motor,would the switch be an issue?


Sent from my iPhone using Tapatalk
Reply
#6
If you unclip the plastic lifter bits from the glass, can you slide it up and down easily by hand? Sometimes the run channel lining can get folded in on itself, this causes massive friction.

Also the command goes in a roundabout fashion. Switch to BSI, BSI to door unit. So you might have a problem with the BSI's output. Lexia will tell you if it "sees" the switch being pressed every time, or just sometimes.
Reply
#7
Thanks mate


Sent from my iPhone using Tapatalk

I presume plugging the passengers switch into the drivers windows and till not workin rules out switch issue?


Sent from my iPhone using Tapatalk
Reply
#8
Go my bsi reset yesterday and all was ok but this afternoon started the same thing again but luckily it came up.any permanent cure guys?????


Sent from my iPhone using Tapatalk
Reply
#9
OMG this is really wrecking my head,new regulator,new switch and still window not going up,just clicking noise from the door card,very occasionally it will go up in stages but rarely. Any help would really be appreciated guys!


Sent from my iPhone using Tapatalk
Reply
#10
Have you checked for water in the bsi?

Seems to me your bsi is playing up
[+] 1 user says Thank You to homeruk for this post
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Poor cold starting. Whats...
Last Post:ron
Today 04:34 PM
» Replies: 4
» Views: 38
Fuel consumption
Last Post:ron
Today 04:30 PM
» Replies: 7
» Views: 118
Lexia clone that works wi...
Last Post:kennard
Today 04:22 PM
» Replies: 60
» Views: 1883
Repair a manual winder wi...
Last Post:cancunia
Today 03:31 PM
» Replies: 1
» Views: 25
lubricating door
Last Post:cancunia
Today 03:25 PM
» Replies: 4
» Views: 110
12v for lighter front
Last Post:cancunia
Today 03:22 PM
» Replies: 18
» Views: 367
1.6 16v petrol cambelt
Last Post:cancunia
Today 03:19 PM
» Replies: 15
» Views: 336
Rear light Cluster
Last Post:Peter Guy
Today 03:13 PM
» Replies: 4
» Views: 101
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 86
"Ultimate" type Diesel fu...
Last Post:ricc
Today 01:56 PM
» Replies: 18
» Views: 474

Locations of visitors to this page