Thread Rating:
  • 4 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Electric Window
Hi guys, my 08 berlingo drivers electric window was a little funny lately (going down when i push up on the switch), and eventually stopped. Replace the regulator inc motor and worked OK for a day or 2, now it went down today and will not come back up!. I hear the motor click like its trying to lift but it dosent!. Any ideas?
Update,changed the switches and drivers window will still no go up

Sent from my iPhone using Tapatalk
[+] 1 user says Thank You to kierc0857 for this post
Thanks guys!

Sent from my iPhone using Tapatalk
Does the glass slide freely?

Can you operate it with Lexia or another comprehensive scan tool that "test fires" body equipment?
Glass stays down,new regulator fitted but all infernos a clicking of the motor,would the switch be an issue?

Sent from my iPhone using Tapatalk
If you unclip the plastic lifter bits from the glass, can you slide it up and down easily by hand? Sometimes the run channel lining can get folded in on itself, this causes massive friction.

Also the command goes in a roundabout fashion. Switch to BSI, BSI to door unit. So you might have a problem with the BSI's output. Lexia will tell you if it "sees" the switch being pressed every time, or just sometimes.
Thanks mate

Sent from my iPhone using Tapatalk

I presume plugging the passengers switch into the drivers windows and till not workin rules out switch issue?

Sent from my iPhone using Tapatalk
Go my bsi reset yesterday and all was ok but this afternoon started the same thing again but luckily it came up.any permanent cure guys?????

Sent from my iPhone using Tapatalk
OMG this is really wrecking my head,new regulator,new switch and still window not going up,just clicking noise from the door card,very occasionally it will go up in stages but rarely. Any help would really be appreciated guys!

Sent from my iPhone using Tapatalk
Have you checked for water in the bsi?

Seems to me your bsi is playing up
[+] 1 user says Thank You to homeruk for this post

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Newbie checking in
Last Post:Johny555
Today 01:57 PM
» Replies: 1
» Views: 14
I'm hearing better or smt...
Last Post:andy-M
Today 01:40 PM
» Replies: 9
» Views: 327
M49 1.9 diesel misfire a...
Last Post:ricc
Today 01:14 PM
» Replies: 6
» Views: 144
Eco activated but engine ...
Last Post:doofer
Today 01:05 PM
» Replies: 25
» Views: 762
Bump and Run - Am I right...
Last Post:doofer
Today 01:00 PM
» Replies: 16
» Views: 242
replacing diesel fuel pip...
Last Post:Col
Today 10:30 AM
» Replies: 36
» Views: 2052
Dead BSI unit?
Last Post:ghost123uk
Today 09:03 AM
» Replies: 5
» Views: 142
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 62
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 63
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 32

Locations of visitors to this page