Thread Rating:
  • 2 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reset bsi on mk3 berlingo
#1
Is there a way to reset the bsi on a mk3 without lexia?


Sent from my iPhone using Tapatalk
Reply
#2
Sure, there is a thread (ore maybe more) on the forum on how to do it. Just run a quick search.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
[+] 1 user says Thank You to 3rensho for this post
Reply
#3
Cheers mate,saw one but not sure unfit works for the mk3


Sent from my iPhone using Tapatalk

Will the bsi reset procedure quoted work for the mk3 ?


Sent from my iPhone using Tapatalk
Reply
#4
Got this from - here and have used it on my B9.

Don't buy a new Bsi (body control unit) for your Citroen until you have read this and tried a factory reset first. Very often the reset will solve a multitude of problems especially the ones that suddenly happened after you fitted a new battery to your Citroen or the ones that just 'appeared' form nowhere!

Wipers stopped working?
Central locking gone mad?
Windows stopped working?
Indicators and lights doing their own thing?

All of the above can be caused by a nutty BSi and often a reset is all it needs so try this....



Put the driver's window down, lift the bonnet and ensure all equipment is switched off.
Ensure all doors are closed and remove key from the ignition.
Wait for 3 minutes, disconnect the vehicle battery and wait 15 seconds.
Reconnect the vehicle battery, wait a further 10 seconds (do not open doors.).
Switch on the side lights through the driver's window.
Switch on the ignition and check system's functionality.
Hold lock button on key down for 10 seconds.
Remove key open & close door test central locking system.
Start the engine and complete the system's check.

Failure to follow this procedure could result in incorrect operation of many BSI related items.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
[+] 4 users say Thank You to 3rensho for this post
Reply
#5
Good answer , very handy to know procedure. Confusedalut:

Is this info on a sticky note ?



thanks 3rensho
Reply
#6
I tried the reset procedure today hoping that it will resolve a problem I have where the rear wash wipe comes on randomly. Does the reset procedure have any kind of feedback like a beep or anything, so that I know the reset has been done? Otherwise I have no way of knowing if I actually got the procedure right or not.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
New PureTech 110 S&S Flai...
Last Post:Jed Clampit
Today 09:04 PM
» Replies: 3
» Views: 49
What website to pass time...
Last Post:Solent
Today 08:32 PM
» Replies: 0
» Views: 20
Berlingo Parts
Last Post:Sb12
Today 07:56 PM
» Replies: 0
» Views: 24
Rear hub nut torque setti...
Last Post:jj9
Today 07:55 PM
» Replies: 15
» Views: 238
temperatue dial
Last Post:Kokain
Today 05:28 PM
» Replies: 3
» Views: 67
Trip Computer on Type A M...
Last Post:cancunia
Today 03:50 PM
» Replies: 0
» Views: 23
Loud beeping from radio u...
Last Post:nicko
Today 03:49 PM
» Replies: 3
» Views: 110
Ligts won't go off!
Last Post:Berlingos12
Today 02:50 PM
» Replies: 10
» Views: 467
DW8 engine tapping
Last Post:brodfather11
Today 08:30 AM
» Replies: 1
» Views: 74
Washers not working
Last Post:Luis Rosa
Today 07:47 AM
» Replies: 8
» Views: 229

Locations of visitors to this page