Thread Rating:
  • 22 Vote(s) - 2.59 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ambient Temperature Sensor
#1
Hello, I have a Berlingo Multispace 2007 1.6Hdi. The ambient (external) temperature sensor has just started to display extreme temperatures...got to over 60C yesterday (I know it's been warm in the UK recently but not that hot Wink )
My question is has anyone actually changed one of these? If so is it (as I suspect) located in base of the off-side mirror (the tear-drop on the bottom?). How easy is it to change? Finally if anyone has changed one how much did the new sensor cost?
Thanks.
Reply
#2
Yeah, mine is under the off-side mirror. Haven't any info on replacement unfortunately.
2010 Berlingo Multispace HDi 110 with FAP. Persamos green.

[Image: ab197646.gif]
Reply
#3
(04-07-2011, 01:39 AM)Multispacer Wrote:  Hello, I have a Berlingo Multispace 2007 1.6Hdi. The ambient (external) temperature sensor has just started to display extreme temperatures...got to over 60C yesterday (I know it's been warm in the UK recently but not that hot Wink )
My question is has anyone actually changed one of these? If so is it (as I suspect) located in base of the off-side mirror (the tear-drop on the bottom?). How easy is it to change? Finally if anyone has changed one how much did the new sensor cost?
Thanks.


Popped into my local Citroen Dealer today and was told that the sensors are £23.50+vat but he went on to tell me they don't go wrong that often, so before I purchase a new one I should check the connections as that can seemingly give a false reading. The guy in the spares department actually said "check the connections on the door board" Is there a circuit board inside the door?
Reply
#4
(04-07-2011, 09:09 PM)Multispacer Wrote:  
(04-07-2011, 01:39 AM)Multispacer Wrote:  Hello, I have a Berlingo Multispace 2007 1.6Hdi. The ambient (external) temperature sensor has just started to display extreme temperatures...got to over 60C yesterday (I know it's been warm in the UK recently but not that hot Wink )
My question is has anyone actually changed one of these? If so is it (as I suspect) located in base of the off-side mirror (the tear-drop on the bottom?). How easy is it to change? Finally if anyone has changed one how much did the new sensor cost?
Thanks.


Popped into my local Citroen Dealer today and was told that the sensors are £23.50+vat but he went on to tell me they don't go wrong that often, so before I purchase a new one I should check the connections as that can seemingly give a false reading. The guy in the spares department actually said "check the connections on the door board" Is there a circuit board inside the door?

Haven't been on here for a while. I did end up changing this and all was OK. Quite a simple job. Carefully lever out the panel on the underside of the mirror containing the sensor [it clips back in afterwards]. Cut the wires off the old sensor. I cut as close to the old sensor as possible as the wires were not very long and I didn't want to make hard work of crimping in the new sensor. Strip the wires back [two on you new sensor and two no the existing wiring] and splice together using two in line splices and a crimp tool [or pliers if you don't have a crimp tool Smile ]
Coil up and excess wire [I strapped mine in a small loop with plastic tie-wrap straps] and clip the temp sensor into the plastic base plate you removed at the beginning. Then refit baseplate on underside of mirror. Only slight problem is they have slightly modified the temp sensor shape at the front end and you have to either cut it or file it down at the front end to get the temp sensor to clip in correctly into the base-plate.

Whole job only took about 15 minutes.
Reply
#5
Hi,
Do you have a part number for this? I need to do mine?

thanks
Reply
#6
ignore that - I will be picking one up from the citroen main stealer at lunch time
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.


  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Fuel consumption
Last Post:ron
Today 04:30 PM
» Replies: 7
» Views: 118
Lexia clone that works wi...
Last Post:kennard
Today 04:22 PM
» Replies: 60
» Views: 1879
Poor cold starting. Whats...
Last Post:jj9
Today 03:58 PM
» Replies: 3
» Views: 36
Repair a manual winder wi...
Last Post:cancunia
Today 03:31 PM
» Replies: 1
» Views: 24
lubricating door
Last Post:cancunia
Today 03:25 PM
» Replies: 4
» Views: 110
12v for lighter front
Last Post:cancunia
Today 03:22 PM
» Replies: 18
» Views: 367
1.6 16v petrol cambelt
Last Post:cancunia
Today 03:19 PM
» Replies: 15
» Views: 336
Rear light Cluster
Last Post:Peter Guy
Today 03:13 PM
» Replies: 4
» Views: 101
Door locking but unlocked
Last Post:ricc
Today 02:25 PM
» Replies: 4
» Views: 86
"Ultimate" type Diesel fu...
Last Post:ricc
Today 01:56 PM
» Replies: 18
» Views: 473

Locations of visitors to this page