Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
td swap.. what am I missing
Im currently fitting a 1.9 td from a m reg 306 to my berlingo (y reg) .. the turbo looks to high and it is fouling on the bulkhead! I have used the 306 engine mounts ect but it looks to be in a completely different place! What am I missing? I thought the chassis were shared? Can anyone shine a light before I set fire to it and get into trouble with the unit landlord!
What motor was in there before?
1.9 non turbo.
I'm sure there was a fellow on here who dropped in a 306 1.9 TD without issue.

Did you use the 306 or Berlingo offside upper rubber mount, also did you bring across the 306 subframe with the Berlingo arms fitted?
Using berlingo subby but I havent got to the stage of worrying about the subframe. It is hhanging on the timing side mount supported by an engine lift. It looks like the exhaust 90degree fouls on the box section part of the bulkhead.
Success! It turned out it just needed taking out and putting back in one more time! I used a sling in a different place instead of the lifting eyes! Dropped right in and sat nice! Clutch tomorrow then boost pipes to the front mount and header tank relocation! Cant wait
Great. I was starting to really wonder why it had stopped you progressing.

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Roof bars for VTR?
Last Post:Jed Clampit
Yesterday 09:40 PM
» Replies: 4
» Views: 84
2005 Berlingo - Aussie Ow...
Last Post:martybelfasthdi
Yesterday 07:50 PM
» Replies: 14
» Views: 262
Eco activated but engine ...
Last Post:doofer
Yesterday 07:50 PM
» Replies: 22
» Views: 503
Front camber out of align...
Last Post:Col
Yesterday 06:46 PM
» Replies: 11
» Views: 236
My Berlingo Camper build....
Last Post:knownowt
Yesterday 06:40 PM
» Replies: 5
» Views: 285
P1351 fault code.
Last Post:Boxer
Yesterday 06:28 PM
» Replies: 13
» Views: 768
Upgrading DAB radio recep...
Last Post:Tree
Yesterday 06:26 PM
» Replies: 14
» Views: 2517
Overheating & part number...
Last Post:kevin58
Yesterday 05:55 PM
» Replies: 36
» Views: 17324
Last Post:ron
Yesterday 04:20 PM
» Replies: 4
» Views: 89
Speedo light not working?
Last Post:brodfather11
Yesterday 04:11 PM
» Replies: 1
» Views: 41

Locations of visitors to this page