Thread Rating:
  • 4 Vote(s) - 2.5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Engine] DW8 Needle lift sensor problem
My Berlingo 1.9D started to be extremely hard to start. Also during driving the engine check light comes on frequently...especially when I release the throttle downhill.

During a diagnostics it came up with two fault codes:
P0170 and P1146. P1146 is saying that the needle lift sensor signal is not readable. The other fault code is related to problem with timing..I believe this is due to the faulty needle lift sensor signal...

Today I fitted a used injector with needle lift sensor which came from a car that had run 23 k. This did not help... When I check the resistance of the sensor is says 103 ohm. Does anybody know if this is the correct value?
Check your cam timing, I wouldn't be surprised if the belt has jumped a tooth.
(12-06-2014, 06:12 AM)Lighty Wrote:  Check your cam timing, I wouldn't be surprised if the belt has jumped a tooth.

If the belt jumped a tooth, should that cause the needle lift sensor to be unreadable? I find it hard to believe that this is the case since the car is intermittently running totally fine...

Any other thoughts? What about the ohm value this sensor should give in working condition?

Forum Jump:

Users browsing this thread: 1 Guest(s)
Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Latest Threads
Injectors and B9 series.....
Last Post:Opensauce
Today 06:55 AM
» Replies: 1
» Views: 39
2004 2.0HDi Cruise Contro...
Last Post:brajomobil
Today 06:29 AM
» Replies: 1
» Views: 50
Radio not working and ele...
Last Post:pscotty
Today 04:02 AM
» Replies: 0
» Views: 21
splayed rear wheels
Last Post:jj9
Yesterday 10:36 PM
» Replies: 7
» Views: 103
Dandav1985's Mk3 Berlingo
Last Post:Jed Clampit
Yesterday 10:16 PM
» Replies: 8
» Views: 243
Bump and Run - Am I right...
Last Post:Jed Clampit
Yesterday 10:13 PM
» Replies: 11
» Views: 161
Still on the elusive 4x10...
Last Post:doofer
Yesterday 08:47 PM
» Replies: 3
» Views: 135
Car smell...
Last Post:doofer
Yesterday 08:03 PM
» Replies: 1
» Views: 82
Dead BSI unit?
Last Post:Kez
Yesterday 07:22 PM
» Replies: 4
» Views: 117
srceen wash pump.
Last Post:landcrab
Yesterday 07:18 PM
» Replies: 7
» Views: 204

Locations of visitors to this page